Thursday, September 28, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  4] [ 0]  / answers: 1 / hits: 18135  / 6 Months ago, thu, april 13, 2023, 6:58:17

I am trying to access a win7 machine that has sharing enabled on a folder. When I mount it on linux it lists all files as -rwxr-xr-x 1 root root

If i sudo i can copy files back and forth but its read only if I dont.

sudo chown [standard_user] *
on the mounted share does nothing.

This mounts the share as read only (all files are root)
sudo mount -t cifs "//myipaddress/myshare" /home/myuser/mymount/ -o username=myusername,password=mypassword,rw

On the win7 box I have myuser and everyone as 'full control'

how do I mount this share so that I dont have to be root to delete/move files?

More From » cifs


Try the following. Works fine for me.

sudo mount -t cifs -o vers=1.0,username=myuser,pass=mypass "//myipaddress/myshare" /home/myuser/mymount/

[#11958] Friday, April 14, 2023, 6 Months  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 43
Total Questions: 125
Total Answers: 102

Location: Gabon
Member since Sat, Jul 25, 2020
3 Years ago