Saturday, May 18, 2024
 Popular · Latest · Hot · Upcoming
0
rated 0 times [  0] [ 0]  / answers: 1 / hits: 973  / 2 Years ago, mon, may 23, 2022, 2:22:20

After upgrading to 4.4.0-59 yesterday I realized today that my zfs partitions were gone! Googling a bit suggested that [http://pastebin.com/BPFj1Ewj ] zfs-native 0.6.5.7 did not like (as in: compile with) the -59 kernel.



Sure enough, zfs is missing from the -59 kernel (check last 2 lines):



% dkms status
bbswitch, 0.7, 4.4.0-53-generic, x86_64: installed
bbswitch, 0.7, 4.4.0-57-generic, x86_64: installed
bbswitch, 0.7, 4.4.0-59-generic, x86_64: installed
nvidia-340, 340.98, 4.4.0-53-generic, x86_64: installed
nvidia-340, 340.98, 4.4.0-57-generic, x86_64: installed
nvidia-340, 340.98, 4.4.0-59-generic, x86_64: installed
spl, 0.6.5.7, 4.4.0-53-generic, x86_64: installed
spl, 0.6.5.7, 4.4.0-57-generic, x86_64: installed
spl, 0.6.5.7, 4.4.0-59-generic, x86_64: installed
virtualbox, 4.3.36, 4.4.0-53-generic, x86_64: installed
virtualbox, 4.3.36, 4.4.0-57-generic, x86_64: installed
virtualbox, 4.3.36, 4.4.0-59-generic, x86_64: installed
zfs, 0.6.5.7, 4.4.0-53-generic, x86_64: installed
zfs, 0.6.5.7, 4.4.0-57-generic, x86_64: installed


Ok, what to do? Reboot under the previously known good kernel (-57)!



After rebooting, sure I can access my zpool, but my partitions are not mounted. To confuse matters even more,

zpool status
suggests I upgrade my pool:




% sudo zpool status
pool: tank
state: ONLINE
status: Some supported features are not enabled on the pool. The pool can
still be used, but some features are unavailable.
action: Enable all features using 'zpool upgrade'. Once this is done,
the pool may no longer be accessible by software that does not support
the features. See zpool-features(5) for details.
scan: none requested
config:

NAME STATE READ WRITE CKSUM
tank ONLINE 0 0 0
mirror-0 ONLINE 0 0 0
ata-ST4000DM000-1F2168_S3014GKE-part4 ONLINE 0 0 0
ata-WDC_WD40PURX-64GVNY0_WD-WCC4E5UZUFFD-part4 ONLINE 0 0 0

errors: No known data errors


Dare I do that? Or, did something get messed up during the failed update to 4.4.0-59? I have installed zfs via

apt-get install ubuntu-zfs
and do not feel brave enough to try to compile and install the zfs module myself. For now, I just want my zfs partitions back!



Update: I have posted the solution that worked below. It might be against askubuntu rules, but I wanted to have this info out as soon as possible if someone else were to run into the same problem.


More From » 14.04

 Answers
0

After a few days an update to zfs-0.6.5.8 appeared. After installing it, re-installing the -59 kernel produced no error messages. However, my partitions were not mounted automatically at boot. A modification to

ZFS_AUTOIMPORT_TIMEOUT='45'
(from 30) in
/etc/defaults/zfs
solved that. So now everything appears to be back to normal!


[#12459] Monday, May 23, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
beateyra

Total Points: 499
Total Questions: 113
Total Answers: 125

Location: Falkland Islands
Member since Mon, Jul 13, 2020
4 Years ago
;