Friday, September 29, 2023
rated 0 times [  75] [ 0]  / answers: 1 / hits: 63479  / 2 Years ago, fri, september 17, 2021, 9:40:49

Today I tried to switch to another shell.

First I tried fish, and used chsh -s fish to change fish to default. After some time I found it cannot use ~/.bashrc (&& needs to be replaced by and).

Because I prefer to reusing ~/.bashrc, I found zsh which seems an easier one and followed this documentation to switch to zsh.

While I was running sh -c "$(curl -fsSL", suddenly it asked me to enter Password:. I entered the root password but got PAM: Authentication failure.

Then I tried chsh -s bash and chsh -s zsh, it always asked me for a password and threw PAM: Authentication failure (not system password). I can't figure this out.

More From » command-line


Thanks to this question on Server Fault, I worked around this by:


auth       required


auth       sufficient

in /etc/pam.d/chsh.

Then it doesn't ask for a password anymore.
But I think it better to restore chsh settings after switching the shell.

[#14102] Sunday, September 19, 2021, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 332
Total Questions: 112
Total Answers: 115

Location: Burkina Faso
Member since Tue, Apr 26, 2022
1 Year ago