Monday, April 15, 2024
2
rated 0 times [  2] [ 0]  / answers: 1 / hits: 1372  / 3 Years ago, sun, august 15, 2021, 2:45:29

I followed this tutorial from youtube for openstack on ubuntu (with autopilot): https://www.youtube.com/watch?v=64HXwmgOQKw



I used ubuntu 16.04 for this, everything was working until I typed "sudo openstack-install". The respond of the CLI was that the command was not found. I had tried installing openstack before with the same steps and did not get the same result on this point. I tried the whole install including an fresh install of the ubuntu server, but still the same result.



I searched on the internet and got the following answer: Is Autopilot Openstack 16.04 available? .



When issuing conjure-up openstack the CLI gave the following error:



enter image description here



I checked every place where that "trusty" could be, but what I find everything was set fine. I also checked the environments.yaml file for JUJU which was set to the right distro version.



Question:



1.) Why is the command not find? How can I solve it?



2.) Why am I getting this error about trusty when using conjure-up? How can I solve it?



P.S. the first question would have been my preference of solving, since that would be more the "normal" way of installing.



P.S.S.



Ubuntu version: Ubuntu 16.04.1 LTS (Xenial)



MAAS version: 2.0.0~rc2+bzr5156-0ubuntu1~16.04.2



JUJU version: 2.0~beta12-0ubuntu1.16.04.1



Commands as "sudo apt-get update" and "sudo apt-get upgrade" has been runned multiple times. Also restarting of the server has been done a couple of times.



Update 1:



I tried the answer of @gangstaluv,but I got the error: Version 0.18 for distro-info-data was not found. I tried to reinstall distro-info-data, but also there no luck. I downloaded the (0.18) package from launchpad and installed it, but then when issuing the command distro-info --lts trusty does an error of command not found. I checked the package by issuing dpkg -s distro-info-data and got back that the package exsists and that the version is 0.18. I hope this is making the issue as clear as possible :)



Update 2:



I find the solution! First I upgraded the MAAS package to version "2.0.0+bzr5189-0ubuntu1" (officially meant for 16.10, but it works). Then I used the solution from ognjen. The combination of these 2 made the installation to not give an error at that point anymore.


More From » command-line

 Answers
5

If you are running MAAS i found in my case that i had to run ephemeral image as 14.04 and deploy image as 16.04. So under images, download both 14.04LTS and 16.04LTS. Under settings make sure commissioning section says 14.04LTS and Deploy sections is set to 16.04LTS.


[#14130] Sunday, August 15, 2021, 3 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
mocipe

Total Points: 161
Total Questions: 106
Total Answers: 118

Location: Cambodia
Member since Thu, Oct 7, 2021
3 Years ago
;