Tuesday, December 5, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  1] [ 0]  / answers: 1 / hits: 9142  / 2 Years ago, sat, january 15, 2022, 9:30:46

I just upgraded my Kubuntu server to Ubuntu 16.04.1 LTS. Now it only gives me the console login on boot - no desktop. It previously booted into kubuntu-desktop. I tried

sudo apt-get purge kubuntu-desktop
sudo apt-get install kubuntu-desktop

(this worked before) but now it still boots to console login only. What do I need to do to get it to boot into kubuntu-desktop?

I can get a root kubuntu-desktop with

sudo startx

but I want a normal, safe, ordinary user desktop.

With many thanks,


More From » boot


To disable the command line interface as default login mode, we need to modify the /etc/default/grub file. TO do so, do the following:

  • Login to your session from the command line (introduce your username, Enter, then the password, Enter again)

  • Open the above file using your default text editor. It could be gedit, or nano. Do so like this:

    sudo gedit /etc/default/grub

  • If you don't know your text editor, try installing any of the above and repeat, as usual:

    sudo apt-get install gedit
    sudo gedit /etc/default/grub

  • Once you are in, look for this line:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash text"

You have to delete the text bit, so it looks like this:


  • Then, save that file (look for he short-cuts at the bottom of the editor).

  • Finally, update the grub:

Then update Grub:

sudo update-grub

Now, restart. There you have the GUI back!

[#14265] Sunday, January 16, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 369
Total Questions: 112
Total Answers: 108

Location: Kenya
Member since Mon, Jun 14, 2021
3 Years ago