Saturday, September 30, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  2] [ 0]  / answers: 1 / hits: 8541  / 10 Months ago, wed, december 28, 2022, 1:09:22

So I have been trying to get my nVidia GPU detected by Ubuntu 20.04 for quite some time now, and none of the suggestions I have found online have helped. My main problem is that I can't see any output when running the suggested commands. Here are the things I have tried:

  1. The first suggestion appears to be to run lspci -v | grep VGA which when I run it in the Ubuntu terminal give no output.

  2. lspci | egrep -i "vga|display|3d" was suggested as well, but no luck.

  3. Another suggestion was to run sudo lshw -C video, again no output.

  4. Also ran lspci -k | grep -A 2 -i "VGA", no output

  5. And finally lspci -nn | grep '[03'

Checking these appears to be the first step in the solution proposed by contributors online, but I can't even get this first step running. Does anyone have suggestions on how I could proceed?


Perhaps I should also specify that I am using a Windows subsystem for Linux. Here are the outputs:

  1. No output

  2. No output

  3. Linux DESKTOP-IQST6BS 5.4.72-microsoft-standard-WSL2 #1 SMP Wed Oct 28 23:40:43 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

  4. Graphics: Message: No Device data found. Display: server: No display server data found. Headless machine? tty: 120x30 Message: No advanced graphics data found on this system.

  5. No output

  6. [ 1.890709] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)

Edit 2

So I have followed the instructions here as recommended, but I still cannot connect to the GPU. For example when I input sudo prime-select nvidia the output is simply Error: no integrated GPU detected.. Can anyone maybe point me to what went wrong here?

More From » 20.04


Given that you have WSL2, you should get the corresponding drivers.
See CUDA on WSL.

For a guide on how to install, please refer to







It is very strange that the commands you posted do not even show your main graphics card.

Possible causes

(Strange hardware issues may be the culprit).

  1. GPU is disabled at the BIOS level. Check that. If you have double boot with Windows, that would be good for a comparison.

  2. Removing and replacing the CMOS battery may help.

  3. An HDMI cable may also be the problem.

Extra / useful info

Please post the output of:

  1. dpkg -l | grep linux-modules-nvidia

  2. dpkg -l | grep nvidia-driver

  3. uname -a

  4. inxi -G (you may have to install inxi)

  5. grep 10de /lib/udev/rules.d/*

  6. dmesg | grep nvidia

  7. dmesg | grep NV



[#1524] Thursday, December 29, 2022, 10 Months  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 361
Total Questions: 103
Total Answers: 113

Location: Turkmenistan
Member since Sun, Aug 2, 2020
3 Years ago
fenddy questions
Tue, Nov 22, 22, 10:11, 11 Months ago
Tue, Sep 27, 22, 09:16, 1 Year ago
Fri, Jun 18, 21, 14:04, 2 Years ago
Wed, Nov 30, 22, 11:15, 11 Months ago