Tuesday, October 3, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  5] [ 0]  / answers: 1 / hits: 15871  / 1 Year ago, wed, october 26, 2022, 3:33:35

I am trying to install Linux onto my new MSI Ghost Pro GS60 6QE computer (I only found out today that MSI is notoriously unreliable with linux) and I am having a lot of trouble. For the whole day I tried to troubleshoot it but to no avail, my situation is this.

I am trying to dual boot my computer with linux using the YUMI pendrive. To get the computer to even recognise the bootable drive I disabled Secure Boot, Fast Boot, Intel Virtualization Technology and Intel Speedstep and also changed "Boot mode select" to Legacy mode.

When I actually run the Ubuntu installer it stalls on the splash screen, when I press escape it shows some process have been completed but seems to freeze on a random process (Eg. in one case it was "Starting Cups ..." and another time it was "Starting WPA"). This happened with all the distros I tried (Xubuntu 15.10, 15.4, 14.4 and Ubuntu 15.10 15.4).

As I am using Yumi and not in grub I don't have access to boot options using f6, all I could do was edit the executable and just replaced "splash screen ---" with "nomodeset ---" and it made no difference other then not loading the splash screen but still stalling on a random process.

My Specs are:

Processor: Intel Core i7-6700HQ CPU @ 2.60GHz 2.59 GHz
Motherboard: Microstar International MS-16H7

I hope someone has run into something similar and can help. If there is anyway to pinpoint the error could someone explain.

Thanks for taking the time, it's been a long day.


More From » boot


Instead of YUMI, use Rufus. It's a lot faster and you'll be able to use UEFI.

When you get to the installer GRUB menu, highlight the "Try Ubuntu" option and press E. Add nouveau.modeset=0 to the end of the line beginning with linux. Also set the nomodeset flag. Press F10 to boot.

Install Ubuntu and reboot. When presented with GRUB, follow the above procedure to boot into Ubuntu. Once booted, install the proprietary NVIDIA drivers by searching for the Additional Drivers app. Use that to select a proprietary driver, then hit Apply and reboot. You shouldn't need the flags again.

[#15861] Wednesday, October 26, 2022, 1 Year  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 118
Total Questions: 95
Total Answers: 117

Location: Virgin Islands (U.S.)
Member since Tue, Jul 7, 2020
3 Years ago