Monday, April 15, 2024
1
rated 0 times [  1] [ 0]  / answers: 1 / hits: 387  / 2 Years ago, fri, february 4, 2022, 4:22:17

I tried installing FMRIB's FSL toolkit on Ubuntu 22.10. The downloaded fslinstaller.py runs absolutely fine without any errors, and clears both stages. It selects /usr/local/fsl as the default install directory. However, when trying to use FSL it is not detected. For instance, echo $FSLDIR returns nothing.I mean it literally returns an empty line. Anything else, including flirt -version and fsleyes simply returns a "not installed" message.


I couldn't find any record of this specific issue, so I figured asking here might help. If anybody has any ideas, you have my advanced gratitude.


More From » software-installation

 Answers
2

Okay, so after a bit of poking around I figured out what the problem was. It appears that you have to relog the shell every time you close your terminal window.


I have to redo the source ~./bash_profile command to get FSL up and running every time.


EDIT (Jan, 8, 2023):


This issue of having to relog the shell after exiting terminal has disappeared on its own with the latest version of FSL. Simply download the new installer and update FSL.


[#166] Saturday, February 5, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
eeperant

Total Points: 39
Total Questions: 106
Total Answers: 117

Location: Finland
Member since Sat, Dec 5, 2020
3 Years ago
;