Thursday, September 28, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  3] [ 0]  / answers: 1 / hits: 3184  / 5 Months ago, tue, may 23, 2023, 12:26:05

I just installed Kubuntu on an Acer Aspire V3 netbook with a SSD using GPT and the following partition layout:

  • 1 MB unformatted partition with boot_grub flag,

  • 200 MB FAT32 partition with boot flag,

  • 2GB swap partition,

  • 20 GB ext4 partition,

  • 90 GB ext4 partition.

The netbook fails to detect my EFI partition. When I disable the secure mode I can access a menu for choosing a boot binary. The menu shows my SSD but no EFI partition on it.

I am only able to boot in legacy mode (using the BIOS partition).
Does anyone has the same netbook booting in EFI mode? What is your partition scheme?

More From » grub-efi


I finally solved the issue, Kubuntu is able to boot with the default UEFI firmware settings (no legacy mode, secure boot enabled). EFI/ubuntu/shimx64.efi needs to be selected once in the UEFI (press F2 during boot, set a supervisor password, then got to Select an UEFI file as trusted for executing and pick EFI/ubuntu/shimx64.efi). The password can be removed afterwards. Here some background information: SHIM (shimx64.efi) is a (Microsoft) signed binary used to call GRUB (grubx64.efi); GRUB then loads the Linux kernel. By the way when I boot in legacy mode Kubuntu is unable to shut down correctly and crashes every time I try to change the mouse settings; this is solved after switching to UEFI mode.

[#18354] Tuesday, May 23, 2023, 5 Months  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 49
Total Questions: 127
Total Answers: 112

Location: Luxembourg
Member since Tue, Jan 25, 2022
2 Years ago