Sunday, September 24, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  4] [ 0]  / answers: 1 / hits: 4569  / 2 Years ago, thu, august 26, 2021, 10:01:21

I recently got a new HP Elitebook G7 laptop and I installed both Windows and Ubuntu in a dual-boot configuration. I tried 20.04 and then moved to 20.10 but I have the same issue no matter the version.

I'm having some trouble getting some of the hardware to work on ubuntu.
The first one is with the fingerprint sensor. The laptop has a Synaptics sensor, I can get the device ID by issuing lsusb

Bus 001 Device 004: ID 06cb:00df Synaptics, Inc.

As far as I understand, this sensor should be supported by libfprint, as it's pretty common.
When I try to register a fingerprint (both with gnome settings and with fprint-enroll via terminal) I get this error: failed to claim device: Open failed with error: The driver encountered a protocol error with the device.
On the second attempt I get failed to claim device: Open failed with error: Device 06cb:00df is already open.
I also just tried to upgrade the firmware of the system with the windows installer (HP website) but nothing changed really.

The sensor works fine on windows, so I definitely know that it works. Any suggestion on how to fix this?

The other issue I have is with the physical buttons above the trackpad, as they do not work. I believe this might be a configuration issue, so I will still experiment a bit more, but of course, any suggestion is more than welcome on this topic too!

More From » drivers


I actually managed to solve the issue with the fingerprint.
I first had to upgrade fwupd to version > 1.5 (the version from apt is lower, but it's possible to install a newer version using snap)

sudo snap install fwupd --classic

Then enable the testing channel and it should find the new firmware.

fwupdmgr enable-remote lvfs-testing
fwupdmgr refresh --force
fwupdmgr update

Finally, disable the testing channel again

fwupdmgr disable-remote lvfs-testing

I had some temporary issue when suspending the PC (keyboard was not responding anymore) that was solved by upgrading the kernel with Ubuntu Mainline (but I'm sure it was something temporary that could have been solved in a simpler way).

[#2094] Saturday, August 28, 2021, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 279
Total Questions: 106
Total Answers: 96

Location: Fiji
Member since Wed, Mar 29, 2023
6 Months ago
uxuriousrnal questions