Thursday, February 22, 2024
 Popular · Latest · Hot · Upcoming
-1
rated 0 times [  -1] [ 0]  / answers: 1 / hits: 1832  / 10 Months ago, thu, may 11, 2023, 6:53:48

// Update: I have had no luck in this issue, and have posted a secondary question here.



The first thing I have done (before posting this questions, was read the guide located on AskUbuntu. This was a very detailed guide, and now that I have Ubuntu 14.04, I will try this again.



Specifications




  • Laptop Model: Toshiba Satellite U50D- Stock. Specs are at this page.

  • Current Install (attempt): Ubuntu 14.0.1 LTS (amd64) ISO, mounted to USB via Lili

  • Error Message: Reboot and select proper boot device, or insert boot media in selected boot device and press a key



My File System {Refer to Notes}



Before I give the details, I will say this- Ubtuntu decided the drive structure automatically, as I do not have a firm understanding of what it should be. I have attempted to re-do the GRUB and Bootloader, and manually mount the drives. This is noted below




  • /dev/sda

  • free space : mb

  • /dev/sda1 efi 536mb (free) 33mb (used)

  • /dev/sda2 ext4 741638mb (free) 15800mb(used) Ubuntu 14.04.1 LTS

  • /dev/sda3 swap 7978 mb (free)

  • free space



My attempt to boot repair



I have tried installing Ubuntu on multiple attempts. I have installed via USB and wiped Windows completely. I have then also tried the option of 'Try Ubuntu without installing' and then installing. On both methods, the Ubuntu installer has recognized the previous install, and I have overwritten it. Once all has installed, it prompts for a reboot..where it gets the above error message. Just to clarify- I have not been able to boot directly to Ubuntu, and there is currently no OS other than Ubuntu 14.04 on this laptop.



The first instance, I installed a Grub repair program and went with that. The guide in which I followed is hosted on the Community. You can view this here. As per the instructions, the first command(s) I ran were as follows:



sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo sed 's/trusty/saucy/g' -i /etc/apt/sources.list.d/yannubuntu-boot-repair-trusty.list
sudo apt-get update
sudo apt-get install -y boot-repair && (boot-repair &)


This went through the terminal with no issue. Once it completed, it recommended I run the following commands:



sudo chroot "/mnt/boot-sav/sda2" dpkg --configure -a
sudo chroot "/mnt/boot-sav/sda2" apt-get install -fy
sudo chroot "/mnt/boot-sav/sda2" apt-get purge -y --force-yes grub* shim-signed linux-signed*


Upon completion, I rebooted and all was the same- no luck!



Repair Grub2



So with the above not working, I tried the next guide. Now, this one I was not so sure on. Because I had booted from the USB, I decided to add an admin account for myself- what was the harm? I was not too certain on this one, so point out any mistakes please!



sudo mount /dev/sda2 /mnt


There were no errors, prompts etc. so I assume when you mount there is no confirmation etc. I then ran the following commands:



sudo mount --bind /dev /mnt/dev &&
sudo mount --bind /dev/pts /mnt/dev/pts &&
sudo mount --bind /proc /mnt/proc &&
sudo mount --bind /sys /mnt/sys


Once again, nothing happened- which is what I expected. I then ran the next command:



sudo chroot /mnt


Now that I was done, I went with the next command of:



grub-install /dev/sda


This is where I ran into the following errors:



E: Failed to fetch http://au.archive.ubuntu.com/ubuntu/pool/main/g/grub/grub_0.97-29ubuntu66_amd64.deb  Could not resolve 'au.archive.ubuntu.com'

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?


I am not sure if an error of the file no longer exists, or is outdated etc. In this instance I did what any idiot does. I improvised.



sudo apt-get install grub or apt-get install grub


When that spat out errors, I reverted to an update:



sudo apt-get update


No help. For those interested, the terminal reads this:



   root@ubuntu:/# apt-get install grub
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
efibootmgr secureboot-db shim
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
grub-common
Suggested packages:
grub-legacy-doc mdadm multiboot-doc grub-emu xorriso desktop-base
The following NEW packages will be installed:
grub grub-common
0 upgraded, 2 newly installed, 0 to remove and 103 not upgraded.
Need to get 2,593 kB of archives.
After this operation, 14.0 MB of additional disk space will be used.
Do you want to continue? [Y/n]


I was then unable to perform the next step, which is:



    exit &&
sudo umount /mnt/sys &&
sudo umount /mnt/proc &&
sudo umount /mnt/dev/pts &&
sudo umount /mnt/dev &&
sudo umount /mnt


With that, I decided to revert back to my System File Stricture.



The Next Step...



I have looked around for a simple guide on how a file-structure should be, and attempted this guide.



As per the instructions, the first step was to do. This was fun..



sudo lshw -c disk


The logical name of my drive is/dev/sda. Awesome, now I follow this up.



Unfortunately I could not find the disk utility (Yo, askubuntu- 10 points for n00b). I went into the next available option...the terminal! I start fdisk with the following:



sudo fdisk /dev/sda


Then enter 'm' for menu, 'n' for new and followed the details. The new partition was made, so then I formatted with:



sudo mkfs -t ext3 /dec/sdb1


I read, then re-read the guide and no luck..no boot device. Frustrated, I tried check disk for defects. Apparently all good. I am greatly exceeded my knowledge of Ubuntu/Linux.



Updates



I have now tried to install Kubuntu, Ubuntu, Lubuntu and Debian- also using different Live USB creators. All has resulted in the same. I have/am purchasing a small SSD and 16GB Ram- we will see if a different hard drive helps the situation.



I gathered as much, as I believe it is an issue with UEFI/Safe Boot and is on the motherboard.


More From » boot

 Answers
2

My solution is based on an answer posted on the question "Installing Ubuntu on a Pre-Installed Windows 8 (64-bit) System (EUFI Supported)." So, I did as follows:



1- I made a parition on my SSD using the default Window's Disk Management Tool



2- I then grabbed the latest version of Rufus and made a bootable EUFI & Safeboot USB with Ubuntu 14.04.1 LTS.



3- I then enabled Secure Boot in my Bios (after performing the CMD command as per the answer on the other question), and continued installing Ubuntu.



Note: I selected Something Else, and manually made my Root 80GB, Swap 5GB and EFI 5GB Now pay attention, this is something I did without reading the guide (although it may be in there..)



After installing the Ubuntu system, I was booting straigh to Window's 8. I followed these steps:



4- I then booted into the Advanced Options (Shift + Restart) and went Advanced Options > Window's Startup Settings > Elected my Ubuntu Boot. Viola! It worked, went straigh to my Ubuntu install with no issues.



For piece of mind, I then used GParted to format my Window's Partition and did a grub repair. Finally, I am now a happy Linux user. Whilst I was unable to boot before to Linux directly, using Dual Boot afforded me the option of electing my boot.



I know this has worked for me, however I cannot confirm if it will work for others.


[#23294] Thursday, May 11, 2023, 10 Months  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
erranbe

Total Points: 118
Total Questions: 95
Total Answers: 117

Location: Virgin Islands (U.S.)
Member since Tue, Jul 7, 2020
4 Years ago
;