Saturday, February 24, 2024
 Popular · Latest · Hot · Upcoming
2
rated 0 times [  2] [ 0]  / answers: 1 / hits: 34976  / 2 Years ago, mon, may 9, 2022, 1:26:07

It's either not intuitive or not working in Ubuntu 14.04.



I want to mount my internal HDD at at startup (I boot from an SSD). I attempt to set this, following this procedure:




  1. Open Disks utility

  2. Select the disk

  3. Below the disk's Volumes, click on the More actions button

  4. Select Edit Mount Options...

  5. Select Automatic Mount Options "Off"

  6. Under Mount Options, ensure that Mount at startup is selected

  7. Click OK

  8. Enter password into Authenticate dialog box

  9. Restart



but this procedure doesn't work. Upon rebooting, and after Grub attempts to start Ubuntu, I receive the error message "An error occurred while mounting /mnt/4f721fc0-8072-453f-b48f-ca686bd89549. Press S to skip mounting or M for manual recovery". That identifier "4f721fc0-8072-453f-b48f-ca686bd89549" was automatically assigned by Ubuntu.



I press S and the boot process continues OK. If I try to mount the disk immediately after booting, I receive the error message "Unable to access "Storage"" (I named the volume Storage).



So then I start the Disks utility and set it to Automatic Mount Options "On" and reboot.



To me, it seems like this should work, but it doesn't.



Here are a number of photos of the process (Alt+PrtScn doesn't work after selecting More actions).


More From » automount

 Answers
5

Yes I finally did this (successfully, it seems so far) by editing fstab.



I would have preferred if it had worked after I tried the intuitive method in the Disks utility.



The process:




  • Google search "ubuntu 14.04 mount internal hdd at startup"

  • Open and read



http://ubuntuforums.org/showthread.php?t=1571781&page=2 and



http://ubuntuforums.org/showthread.php?t=1571781&page=3 and



http://ubuntuforums.org/showthread.php?t=1571781&page=4 and



Unable to mount hard-disk at startup and



problem mounting second harddrive with ubuntu 14.04 and



How do I get my internal HDD to mount at startup? and



https://help.ubuntu.com/community/Fstab and



http://ubuntuforums.org/showthread.php?t=283131 and



https://help.ubuntu.com/community/AutomaticallyMountPartitions#Per-User_Mounts




  • Go to /etc/fstab file

  • Right-click on file and run Script 'open-as-administrator'

  • Add




# mount 4f721fc0-8072-453f-b48f-ca686bd89549/sdb1/Storage at boot
UUID=4f721fc0-8072-453f-b48f-ca686bd89549 /media/el_gallo_azul/Storage ext4 defaults 0 2




  • Test by rebooting

  • Determined to be successful by Dropbox not showing 'Dropbox folder not found' error message that it had always shown at the end of booting previously.



I'm now one step closer to getting BOINC to use my internal HDD instead of my SSD for its data directory. I'll keep chipping away until I achieve it.



By the way, I had a little look in the Disks utility settings after I did this, and indeed the settings were exactly the same as what I tried to set via the intuitive method.


[#23605] Tuesday, May 10, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
splenueak

Total Points: 448
Total Questions: 118
Total Answers: 110

Location: Vanuatu
Member since Mon, Oct 3, 2022
1 Year ago
;