Wednesday, September 27, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  0] [ 0]  / answers: 1 / hits: 2834  / 1 Year ago, sat, may 14, 2022, 3:04:09

I have a MAAS cluster controller with two NIC (eth0 - - connected to public network and p1p1 - - used for private MAAS nodes). I use 5 physical machines HP compaq 6000 Pro. When I turn on one of these machines, it correctly does PXE boot from the MAAS cluster controller and in the MAAS console it is shown as "declared". There is a warning icon next to the hostname with error:

This node does not have a power type set and MAAS will be unable to control it. Click 'Edit node' and set one.

Also, it shows 0 CPU, Memory and disk space.

When, I update the power type to "Wake-on-LAN" with the correct MAC and save, I'm not able to commission the node. It does not turn on the machine and hangs on the "commissioning" status. I checked time is correctly set on the node (check in BIOS).

The WOL with the node works just fine, i.e., I can turn it on using:

wakeonlan -i 00:23:24:0e:0d:e7

from the MAAS cluster controller. I have to specify the -i since the default does not do anything.

If I turn it on manually (e.g. using wakeonlan) it eventually goes into ready state and correctly detects CPU, Memory and disk space. Again, if I try to start the, it wont do anything, but if I power it on manually, it works just fine.


It seems that the problem is related to having two NICs - the magic packet is only sent over the eth1 (even though the cluster is correctly configured indicating p1p1 as the managed interface) which is incorrect (sudo tcpdump -i eth1 port 9 -vvvv -s0 -n). Submitted a bug

More From » maas


There is a solution. The actual command used by MAAS to wakeonlan the machines is specified in a template file.

You just have to edit this template file:

sudo vim /etc/maas/templates/power/ether_wake.template

There will be a line with:

/usr/bin/wakeonlan $mac_address

Just change it to include the broadcast address of the network as you did in your command:

/usr/bin/wakeonlan -i $mac_address

[#24092] Monday, May 16, 2022, 1 Year  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 330
Total Questions: 111
Total Answers: 95

Location: Sint Maarten
Member since Tue, Mar 29, 2022
2 Years ago