Wednesday, September 27, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  4] [ 0]  / answers: 1 / hits: 4739  / 2 Years ago, tue, september 28, 2021, 11:39:54

I just built a new computer last week, and this weekend I got around to attempting to install Ubuntu 14.04 on it besides Windows 7. This is my first experience really using UEFI, so I was a little surprised that the install process didn't just work for me. No matter what I did, I always ended up with a prompt saying

Unable to find a medium containing a live file system

and I was unable to type anything, though that may be due to my wireless keyboard (wired is on the way). This prompt always comes up after sitting at the Ubuntu loading screen for about ~2-3 minutes.

I made sure the ISO I downloaded was fine by checking the MD5Sum. Rebuilt the bootable usb (using UNetbootin) twice, no luck. The only thing I was not able to do was turn off secure boot, because I was not able to find the option on my motherboad (Gigabyte 970A-UD3P). I'm not even sure if that's a UEFI feature, or if it's just a Windows 8 feature.

I have verified that I am indeed using USB2.0 ports, and not USB3.0. I am rather lost and not sure how to proceed at this point. Any more guidance would be greatly appreciated! I really despise developing on Windows -_-

EDIT: more attempts:
Ok, I have tried this some more. I have now used Rufus, LiveLinux USB Creator, and Universal USB Installer. None of these have done it either. I have bought a brand new flash drive, that didn't work. Every single time it is the same story. Ubuntu loading screen for about 2 minutes, then kicked into an ash console with the message of "Unable to find a medium containing a live file system". I'm not even able to type at all at this point, so I can't really get any more information. This is incredibly frustrating. I have never had this much trouble getting Linux installed before.


Gigabyte 970A-UD3P

AMD FX8350

GTX 760

Skill Ripjaw 2x4GB RAM


More From » boot


While a different model Gigabyte mother board this may also apply.

Gigabyte GA-X79-UD3 with I7-3820
Needed F6 to set ACPI=Off.and nomodeset

Gigabyte UEFI boot issues - The partition size of the created USB Installer device needs to be under that of 4GB.
Others found UEFI/BIOS update solved issue of 4GB FAT limit.

turns out the IOMMU needs to be enabled in the BIOS. This problems seems to be exclusive to Gigabyte boards.

Some more related info:
IOMMU for USB3 ports Gigabyte board

Linux kernel enable the IOMMU – input / output memory management unit support - AMD

[#24451] Wednesday, September 29, 2021, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 39
Total Questions: 106
Total Answers: 117

Location: Finland
Member since Sat, Dec 5, 2020
3 Years ago