Monday, February 26, 2024
 Popular · Latest · Hot · Upcoming
13
rated 0 times [  13] [ 0]  / answers: 1 / hits: 21783  / 2 Years ago, mon, february 7, 2022, 4:20:44

I'm running Xubuntu 13.10 with xfce4-panel 4.10.1 and my sessions keeps getting saved involuntarily. I'm well aware that this is a bug so I'd like to ask if anyone knows a workaround to permanently disable/delete this feature (by removing/editing some files maybe)?



I've spent hours searching and tried a lot of the methods already but none of them worked, or at least were not permanent. Some of the stuff I've tried:


How can I turn off Xfce session saving system-wide?

(This basically just removed the tick-box in the logout prompt)


Xubuntu reopens last session applications even though it shouldn't

(Deleting the cached sessions was not a permanent solution)



I would greatly appreciate your help!




My temorarily solution:
I created a simple bash script and placed an
application launcher (which runs the script when pressed) on my task
panel. The script will delete the "~/.cache/sessions" directory and
promt log out.



The script can be found here: http://pastebin.com/aqx483pn



Basically this will be the button which you use to logout/reboot/shutdown.






Update: This only occurs if you added "restart" to the listing, in your "Action Button" (the button with your username written on). If you restart using log out -> restart it should reboot normally and not save your session. Thus, the temporarily solution above is not necessary, I will leave it there as a reference.


More From » xubuntu

 Answers
3

The solution is two-step.




  1. Disable Automatically save sessions on logout in Settings > Sessions > General > Logout Settings. Also make sure that you disable Save session for future logins in the Logout prompt (the window that pops when you actually try to logout).



    See:




  2. You need to log out, delete the contents of ~/.cache/sessions, then log into a clean session. (You can also delete your current session via Settings > Sessions > Session > Clear Saved Sessions.)



    See:





[#26752] Wednesday, February 9, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
torlim

Total Points: 408
Total Questions: 113
Total Answers: 110

Location: Estonia
Member since Wed, May 27, 2020
4 Years ago
;