Thursday, May 23, 2024
 Popular · Latest · Hot · Upcoming
0
rated 0 times [  0] [ 0]  / answers: 1 / hits: 3635  / 3 Years ago, sun, october 31, 2021, 4:49:39

I have a Ubuntu 12.04 x32 running in a Chroot environment (using Crouton) on my Chromebook. It runs perfectly, and can access the internet. However, it cannot access computers on the local network (it won't discover Minecraft LAN devices, but others can discover and NOT connect to mine), and it won't discover or connect to any LAN devices in Nautilus (error message when opening "Windows Network" saying "Unable to Mount location" and "Failed to retrieve share list from server").



Here is my /etc/hosts file, as default when installed:




127.0.0.1 localhost
::1 localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters


Can someone please help me with this? I need to access samba shares (Raspberry Pi NAS and my desktop computer file shares), and Minecraft LAN would be a bonus :)


More From » chroot

 Answers
4

I have found a solution! I didn't see it before because it is for servers, but it worked anyway: https://askubuntu.com/a/146669/48364



It involves editing /etc/nsswitch.conf by moving "dns" before [NOTFOUND=return] instead of after.



I tried it and I can now access my Raspberry Pi NAS!


[#26982] Tuesday, November 2, 2021, 3 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
anxietunnel

Total Points: 66
Total Questions: 120
Total Answers: 115

Location: Norway
Member since Sat, Mar 4, 2023
1 Year ago
;