Saturday, May 18, 2024
 Popular · Latest · Hot · Upcoming
2
rated 0 times [  2] [ 0]  / answers: 1 / hits: 13047  / 2 Years ago, wed, february 2, 2022, 3:20:27

I've installed the deb fie for mysql version 6 ... and when I've typed :



sudo dpkg -i mysql-6.deb 


I've gotten the following error :



cannot access archive : no such file or directory 
errors were encountered while processing: mysql-6.deb


the result of ls -lah :



teeba@ubuntu:~$ ls -lah
total 54K
drwxr-xr-x 24 teeba teeba 1.0K Feb 11 13:10 .
drwxr-xr-x 3 root root 1.0K Feb 9 07:33 ..
-rw------- 1 teeba teeba 682 Feb 11 12:04 .bash_history
-rw-r--r-- 1 teeba teeba 220 Feb 9 07:33 .bash_logout
-rw-r--r-- 1 teeba teeba 3.5K Feb 9 07:33 .bashrc
drwx------ 20 teeba teeba 1.0K Feb 11 11:29 .cache
drwxrwxr-x 3 teeba teeba 1.0K Feb 10 03:07 .compiz-1
drwx------ 14 teeba teeba 1.0K Feb 11 11:14 .config
drwx------ 3 teeba teeba 1.0K Feb 9 15:35 .dbus
drwxr-xr-x 4 teeba teeba 1.0K Feb 11 11:19 Desktop
-rw-r--r-- 1 teeba teeba 25 Feb 11 13:10 .dmrc
drwxr-xr-x 2 teeba teeba 1.0K Feb 9 15:35 Documents
drwxr-xr-x 2 teeba teeba 1.0K Feb 9 15:35 Downloads
-rw-r--r-- 1 teeba teeba 8.3K Feb 9 07:33 examples.desktop
drwxr-xr-x 2 teeba teeba 1.0K Feb 10 11:03 .fontconfig
drwx------ 5 teeba teeba 1.0K Feb 11 13:10 .gconf
-rw-r----- 1 teeba teeba 0 Feb 11 11:06 .gksu.lock
drwx------ 4 teeba teeba 1.0K Feb 9 15:35 .gnome2
-rw------- 1 teeba teeba 0 Feb 9 15:39 .goutputstream-7OXQAX
-rw------- 1 teeba teeba 0 Feb 11 11:31 .goutputstream-NHM7AX
-rw------- 1 teeba teeba 0 Feb 10 09:57 .goutputstream-V2USAX
drwxrwxr-x 2 teeba teeba 1.0K Feb 10 08:11 .gstreamer-0.10
-rw-rw-r-- 1 teeba teeba 137 Feb 11 13:10 .gtk-bookmarks
dr-x------ 2 teeba teeba 0 Feb 11 13:10 .gvfs
-rw------- 1 teeba teeba 2.5K Feb 11 13:10 .ICEauthority
drwxr-xr-x 3 teeba teeba 1.0K Feb 9 15:35 .local
drwx------ 3 teeba teeba 1.0K Feb 9 15:35 .mission-control
drwx------ 4 teeba teeba 1.0K Feb 10 03:14 .mozilla
drwxr-xr-x 2 teeba teeba 1.0K Feb 9 15:35 Music
-rw-rw-r-- 1 teeba teeba 0 Feb 10 08:31 mysql-5.6.deb
drwxr-xr-x 2 teeba teeba 1.0K Feb 11 12:04 Pictures
-rw-r--r-- 1 teeba teeba 675 Feb 9 07:33 .profile
drwxr-xr-x 2 teeba teeba 1.0K Feb 9 15:35 Public
drwx------ 2 teeba teeba 1.0K Feb 11 13:10 .pulse
-rw------- 1 teeba teeba 256 Feb 9 15:35 .pulse-cookie
drwxr-xr-x 2 teeba teeba 1.0K Feb 9 15:35 Templates
drwx------ 4 teeba teeba 1.0K Feb 9 15:36 .thumbnails
drwxr-xr-x 2 teeba teeba 1.0K Feb 9 15:35 Videos
-rw------- 1 teeba teeba 51 Feb 11 13:10 .Xauthority
-rw------- 1 teeba teeba 1.7K Feb 11 13:10 .xsession-errors
-rw------- 1 teeba teeba 5.8K Feb 11 12:05 .xsession-errors.old


how do i install .deb files in an easy way ??



UPDATE :



I've typed as in the answer :



sudo dpkg -i '/home/teeba/Desktop/mysql-workbench-community-6.0.9-1ubu1204-i386.deb'


and gotten the following :



Selecting previously unselected package mysql-workbench-community:i386.
(Reading database ... 141848 files and directories currently installed.)
Unpacking mysql-workbench-community:i386 (from .../mysql-workbench-community-6.0.9-1ubu1204-i386.deb) ...
dpkg: dependency problems prevent configuration of mysql-workbench-community:i386:
mysql-workbench-community:i386 depends on libatkmm-1.6-1 (>= 2.22.1).
mysql-workbench-community:i386 depends on libc6 (>= 2.4).
mysql-workbench-community:i386 depends on libcairo2 (>= 1.8.0).
mysql-workbench-community:i386 depends on libctemplate0.
mysql-workbench-community:i386 depends on libgcc1 (>= 1:4.1.1).
mysql-workbench-community:i386 depends on libgdk-pixbuf2.0-0 (>= 2.22.0).
mysql-workbench-community:i386 depends on libglib2.0-0 (>= 2.31.8).
mysql-workbench-community:i386 depends on libglibmm-2.4-1c2a (>= 2.32.0).
mysql-workbench-community:i386 depends on libgnome-keyring0 (>= 2.22.2).
mysql-workbench-community:i386 depends on libgtk2.0-0 (>= 2.24.0).
mysql-workbench-community:i386 depends on libgtkmm-2.4-1c2a (>= 1:2.24.0).
mysql-workbench-community:i386 depends on liblua5.1-0.
mysql-workbench-community:i386 depends on libmysqlclient18 (>= 5.5.13-1).
mysql-workbench-community:i386 depends on libpango1.0-0 (>= 1.18.0).
mysql-workbench-community:i386 depends on libpangomm-1.4-1 (>= 2.27.1).
mysql-workbench-community:i386 depends on libpcre3 (>= 8.10).
mysql-workbench-community:i386 depends on libpcrecpp0 (>= 7.7).
mysql-workbench-community:i386 depends on libpython2.7 (>= 2.7).
mysql-workbench-community:i386 depends on libsigc++-2.0-0c2a (>= 2.0.2).
mysql-workbench-community:i386 depends on libsqlite3-0 (>= 3.5.9).
mysql-workbench-community:i386 depends on libstdc++6 (>= 4.6).
mysql-workbench-community:i386 depends on libtinyxml2.6.2.
mysql-workbench-community:i386 depends on libuuid1 (>= 2.16).
mysql-workbench-community:i386 depends on libx11-6.
mysql-workbench-community:i386 depends on libxml2 (>= 2.7.4).
mysql-workbench-community:i386 depends on libzip2 (>= 0.10).
mysql-workbench-community:i386 depends on python-paramiko.
mysql-workbench-community:i386 depends on python-pexpect.
mysql-workbench-community:i386 depends on python-pysqlite2.
dpkg: error processing mysql-workbench-community:i386 (--install):
dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme ...
Processing triggers for shared-mime-info ...
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Errors were encountered while processing:
mysql-workbench-community:i386
teeba@ubuntu:~$


There is a problem in dependencies... how to solve that ??


More From » 12.04

 Answers
7

I think your problem that the mysql workbench You've downloaded is for 32 bit ubuntu 12.04.



If your ubuntu is 64 bit you should download the 64bit version of mysql workbench from here



if you issue the command



uname -a 


in the terminal you should see something written like this:




3.2.0-58-generic #88-Ubuntu SMP Tue Dec 3 17:37:58 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux




Then the key is x86_64 means that this is a 64bit OS


[#27051] Thursday, February 3, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
imberst

Total Points: 370
Total Questions: 107
Total Answers: 123

Location: French Polynesia
Member since Tue, Jul 7, 2020
4 Years ago
;