Thursday, May 23, 2024
 Popular · Latest · Hot · Upcoming
1
rated 0 times [  1] [ 0]  / answers: 1 / hits: 7384  / 2 Years ago, sat, february 12, 2022, 7:49:00

Since the last apt-get dist-upgrade this morning, I've started seeing nvidia-settings crashes when I try setting something with the error below:



$ The program 'nvidia-settings' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
(Details: serial 666 error_code 2 request_code 139 minor_code 25)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)


Having spent a few hours already I've tried several things below and no luck:




  • Rename ~/.nvidia-settings-rc --> New file was made at some point I'm not sure.

  • Rename /etc/X11/xorg.conf --> New file hasn't been generated.

  • Install bumblebee --> Had same situation with this ticket and gave up. Uninstalled.

  • Tried installing and/or removing nvidia's libraries (versions tried: 304, 319, 331 afai remember)



Since it looks like the latest nvidia driver 331.20 was just released early this morning, I suspect the newly installed library contains a wrongdoer. But does anyone have an idea to fix this?



System logs:



$ cat /etc/issue
Ubuntu 12.04.4 LTS
l

$ uname -a
Linux 130s-serval 3.2.0-58-generic #88-Ubuntu SMP Tue Dec 3 17:37:58 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

$ for keyword in baseboard-manufacturer baseboard-product-name baseboard-version system-manufacturer system-product-name system-version bios-vendor bios-version bios-release-date; done
> printf "%-22s: " "$keyword";
> sudo dmidecode -s "$keyword";
> done
System76, Inc.
baseboard-product-name: Serval Professional
baseboard-version : serp7
system-manufacturer : System76, Inc.
system-product-name : Serval Professional
system-version : serp7
bios-vendor : American Megatrends Inc.
bios-version : 4.6.4
bios-release-date : 06/01/2011

$ dpkg -p nvidia-settings |grep Version
Version: 331.20-0ubuntu0.0.1


Thanks!


More From » nvidia

 Answers
0

Yes, as @Eric suggested downgrading to 304.88 works. As I was on i386 and was missing a few dependencies had to go through a few more steps. The following should solve it for people using i386.



First download the i386 package



wget http://http.us.debian.org/debian/pool/contrib/n/nvidia-settings/nvidia-settings_304.88-1_i386.deb


The package has a few dependencies, we need'em installed before dpkging the above package. (In my case I was missing nvidia-installer-cleanup and libxnvctrl0):



wget http://http.us.debian.org/debian/pool/contrib/n/nvidia-support/nvidia-installer-cleanup_20131102+1_i386.deb
wget http://http.us.debian.org/debian/pool/contrib/n/nvidia-settings/libxnvctrl0_319.72-1_i386.deb


In order to dpkg - nvidia-installer-cleanup, we need to do a little clean-up.



sudo apt-get remove nvidia-current nvidia-current-updates nvidia-common


After the above packages have been removed you can dpkg the downloaded packages one by one.



sudo -i
dpkg nvidia-installer-cleanup_20131102+1_i386.deb
dpkg libxnvctrl0
dpkg nvidia-settings_304.88-1_i386.deb


Once, you have rolled back to version 304.88 and do not want it to update it, you can lock the version as follows:



echo “nvidia-settings-304 hold” | dpkg --set-selections


In future, if you'd want to remove the hold, you can do:



echo “nvidia-settings-304 install” | dpkg --set-selections


NOTE: You can also use the synaptic package manager. Just select your package, and from the package menu select Lock Version.


[#27244] Sunday, February 13, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
tinchir

Total Points: 300
Total Questions: 116
Total Answers: 119

Location: American Samoa
Member since Sun, Jan 17, 2021
3 Years ago
;