Thursday, February 22, 2024
 Popular · Latest · Hot · Upcoming
2
rated 0 times [  2] [ 0]  / answers: 1 / hits: 32654  / 3 Years ago, wed, may 26, 2021, 3:14:02

I've been having issues getting X11 to work lately - several hours of googling and trying various fixes have got me nowhere. Here's the specifics:




  • I am trying to log in to a department computer from my laptop via ssh -X over the local network. X11 worked perfectly for quite some time, then all of a sudden I started getting the error message: X11 connection rejected because of wrong authentication

  • I have tried about 6 different things to remedy this. I thought I had it working last week by modifying my local copy of /etc/ssh/ssh_config, specifically I uncommented the line ForwardX11Trusted yes. This apparently was a fluke because now it isn't working again

  • I have also tried adding my MIT-MAGIC-COOKIE to the remote machine using xauth add, but this hasn't seemed to work.

  • Tried everything here, in particular I have permissions for .Xauthority and my discs are nowhere near full (local and remote).



Here are the outputs of my various environment variables and so forth:



$ echo $DISPLAY # local machine 
:0.0

$ echo $DISPLAY # remote machine
localhost:10.0

$ xauth list # local
laptop/unix:0 MIT-MAGIC-COOKIE-1 45f1f58762e8040da75508d23df6819e

$ xauth list # remote
# blank


I image this last one is the key, but repeated attempts at xauth add on the remote machine don't seem to change this.



Any ideas? Let me know if I can provide any more outputs. Thanks!


More From » ssh

 Answers
0

This ended up being an Occam's Razor: the simplest explanation was true:



$ df -H
Filesystem Size Used Avail Use% Mounted on
grad2:/u6/#username 247G 113G 121G 49% /u6/#username


Looks like I have tons of room, right? Well, turns out I actually have a quota on that disc, which turned out to be full:



$ quota
Disk quotas for user #username (uid #####):
Filesystem blocks quota limit grace files quota limit grace
grad2:/u6/#username
1698264 1700000 1700000 12742 0 0


Cleared out a few files, had the admin increase the quota, and viola: X11 works again. Why on earth couldn't it have a useful error message like "cannot start X11 because your quota/disc is full"?? I probably wasted 5 hours on this.


[#28404] Thursday, May 27, 2021, 3 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
itteast

Total Points: 291
Total Questions: 123
Total Answers: 104

Location: Tuvalu
Member since Wed, Mar 29, 2023
12 Months ago
;