Saturday, September 23, 2023
rated 0 times [  9] [ 0]  / answers: 1 / hits: 3321  / 9 Months ago, mon, january 9, 2023, 3:33:22

I'm using Ubuntu 13.10, but I think the keyboard shortcut wasn't bound in 12.10, but could be wrong.

It's not in the shortcuts tab of keyboard settings. How can I change the Unicode input from Ctrl+Shift+U to other?

More From » shortcut-keys


Control+Shift+u for unicode input is hard-coded into the GTK+3 default input method. (Source: GtkIMContext).

The easiest thing to do is probably to use a different set of keys for whatever functions you need.

But you have some other options for Gtk applications. Both involve replacing the default input method with no input method.

In gedit and in gnome-terminal, you can right-click the window and choose Input Methods >> None. This may be a good solution if you do not need an input method for other reasons and do not need the features of LibreOffice.

For LibreOffice, there does not appear to be a way to bypass the system input method. If you do not need an input method, you can turn it off system-wide by going to System Settings >> Language Support and setting Keyboard input method system to none. You must reboot for this to take effect. (Logging out was not enough.)

Note that this method is only hard-coded into Gtk applications. If you do not mind installing KDE dependencies, you can use an editor like kate and change the accelerators to suit your need.

[#28674] Tuesday, January 10, 2023, 9 Months  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 1
Total Questions: 112
Total Answers: 114

Location: Lesotho
Member since Wed, Jun 2, 2021
2 Years ago
girdleas questions
Fri, Jun 18, 21, 04:41, 2 Years ago
Thu, Mar 10, 22, 00:17, 2 Years ago
Wed, May 18, 22, 22:02, 1 Year ago