Monday, February 26, 2024
 Popular · Latest · Hot · Upcoming
2
rated 0 times [  2] [ 0]  / answers: 1 / hits: 89194  / 1 Year ago, thu, november 10, 2022, 10:21:45

I installed Ubuntu 13.04 while Windows 7 dual booted. I have a Local wired cable connection which is working fine with windows 7, but in the case of Ubuntu it is not working. I try to connect using Network Connections and Ipv4 Settings, in Method option. I use Manual and put all the addresses which my Internet Service Provider has given to me, but whenever I am going to save the Save... button grayed out. I have collected some data regarding this issue. using,



lspci -nnk | grep -iEA3 "(network|wireless|ethernet)"


it shows,



03:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
Subsystem: AzureWave AW-NB037H 802.11bgn Wireless Half-size Mini PCIe Card [AR9002WB-1NGCD] [1a3b:2c37]
Kernel driver in use: ath9k
04:00.0 USB controller [0c03]: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller [1b21:1042]
Subsystem: ASUSTeK Computer Inc. Device [1043:1059]
--
05:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0)
Subsystem: ASUSTeK Computer Inc. Device [1043:1851]
Kernel driver in use: atl1c


and



sudo ifconfig


it shows,



eth0      Link encap:Ethernet  HWaddr c8:60:00:43:c7:82  
inet6 addr: fe80::ca60:ff:fe43:c782/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:985 errors:0 dropped:16 overruns:0 frame:0
TX packets:32 errors:0 dropped:0 overruns:0 carrier:1
collisions:0 txqueuelen:1000
RX bytes:71604 (71.6 KB) TX bytes:6652 (6.6 KB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:144 errors:0 dropped:0 overruns:0 frame:0
TX packets:144 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:11744 (11.7 KB) TX bytes:11744 (11.7 KB)

wlan0 Link encap:Ethernet HWaddr 00:08:ca:f0:51:5a
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


Can anyone suggest how I can fix this and connect to my wired connection?


More From » ethernet

 Answers
3

It seems that you do not have an IPv4 address. To set this:



First, open the terminal, and then type the following:



sudo nano /etc/network/interfaces


This will open a file, type the following in the file:



auto eth0
iface eth0 inet static
address 192.168.1.100
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1


(Enter your own IP addresses instead the above.) Or, if you do not want a static IP, just type the following lines in the file:



auto eth0
iface eth0 inet dhcp


Save the file (CTL+X, Y, enter) and restart the network service:



sudo service network-manager restart


Hope this helps.


[#30030] Saturday, November 12, 2022, 1 Year  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
suspengn

Total Points: 477
Total Questions: 104
Total Answers: 100

Location: Rwanda
Member since Thu, Feb 10, 2022
2 Years ago
;