Thursday, September 28, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  31] [ 0]  / answers: 1 / hits: 47283  / 1 Year ago, wed, july 13, 2022, 1:00:20

UPDATE Aug 2017: The solution marked as accepted by me apppears to have worked until Ubuntu 15.10. For 16.04+ choose one of the more recent solutions.

For 16.04+ the config file is /etc/bluetooth/main.conf NOT /etc/bluetooth/audio.conf .

I have a bluetooth speaker, Sony SRS-BTX300, which works in linux/ubuntu 13.04, but only after some fiddling. (Update Dec 2013: same problems remain in 13.10)

I have to set the preferred bandwidth mode to "High fidelity playback" (A2DP) each time after switching on the computer and reconnecting the speaker.

The mode resets itself to "telephony/duplex" (=low bandwidth) every time. It takes about 20 clicks to reset the speaker, (click through menu, disconnect, reconnects, select mode, test), and these are definitely too many clicks.

How can I make "A2DP" mode the default mode, an do so in a persistent manner?

A few screen shots will illustrate.

After choosing this menu by clicking on the bluetooth icon in the top panel in Unity...

Bluetooth Icon on panel

After setting up this...


... the preferred mode will be reset to this after restarting/suspending the computer

Telephony Duplex

More From » unity


There's an option in /etc/bluetooth/audio.conf called aAutoConnect=truewhich is hashed out.

sudo nano /etc/bluetooth/audio.conf

Delete the "#" at the start of the AutoConnect=true line

I found enabling this option by removing the # and got things connecting properly with my bluetooth headset

Restart the bluetooth service for the change to take effect:

sudo service bluetooth restart

[#30330] Thursday, July 14, 2022, 1 Year  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 116
Total Questions: 118
Total Answers: 104

Location: Solomon Islands
Member since Fri, Oct 8, 2021
2 Years ago