Tuesday, September 26, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  6] [ 0]  / answers: 1 / hits: 28589  / 10 Months ago, thu, december 8, 2022, 8:15:10

I've a partition on /dev/sda2 of 279 GB Ext4 filesystem, but I'm not able to auto mount it on login.

I've added the partition entry /dev/sda /home ext4 defaults 0 0 in /etc/fstabt still it does not auto mount.

I've even tried to edit the mount options from disks (please see the below screenshot), yet no results.

The udisks command works well but the problem is that, it asks a admin password for standard user.

So my question is how do I auto mount this partition or at least grant read write permission to standard user so that they can mount this partition using udisks command.

enter image description here

Thanks to dschinn1001 I was able to automount my partition by editing the entry in fstab.

First I fount the UUID using sudo blkid

Then edit the fstab file using sudo /etc/fstab

Add the entry in the following format

[Device] [Mount Point] [File System Type] [Options] [Dump] [Pass]

Device will be your UUID

Mount Point will be the location where you want to mount your partition

File System Type will be displayed when you run blkid command

Options Add the options you need. See options in Fstab for more details.

Dump This value will be zero most cases. See Fstab for more details.

Pass This value will be zero most cases. See Fstab for more details.

So finally this is how my entry looks like.

UUID=fe9ab5ba-35ed-49c5-b1d3-9bfc02060867 /media/mount ext4 auto,user,rw,exec 0 0

Save the file and restart your PC.

In the options I've mentioned

auto which means auto mount

user which means grant standard users to mount partition

rw read write permission

exec Permit the execution of binaries from the filesystem

More From » 12.10


partition entry is not quite correct ( /home is in /dev/sda2 ? ) :

you wrote:

/dev/sda /home ext4 defaults 0 0

( if you write like that then you should replace /dev/sda


you can determine UUID-number with command: sudo blkid)

but it could look like this too ( in older Linux-Versions):

/dev/sda /mnt/ext4 defaults 0 0

or like this:

/dev/sda /media/ext4 defaults 0 0

more is explained here :




[#30818] Friday, December 9, 2022, 10 Months  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 292
Total Questions: 106
Total Answers: 115

Location: Cape Verde
Member since Fri, Sep 16, 2022
1 Year ago