Saturday, May 18, 2024
 Popular · Latest · Hot · Upcoming
6
rated 0 times [  6] [ 0]  / answers: 1 / hits: 49812  / 2 Years ago, tue, february 8, 2022, 7:34:08

  • I have Intel Centrino Wireless-N 1000

  • I installed hostapd from Ubuntu Software Center

  • When I run this command hostapd hostapd-minimal.conf I get this:



    root@tarek-PC:~# hostapd hostapd-minimal.conf
    Configuration file: hostapd-minimal.conf
    Line 2: invalid/unknown driver 'nl80211 '
    Line 4: unknown hw_mode 'g '
    2 errors found in configuration file 'hostapd-minimal.conf'






After doing make first I had this error:



driver_nl80211.c:25:26: warning: netlink/attr.h: No such file or directory


I solved it by installing libnl-1.0pre8



Now I have this error when doing make command:



../src/crypto/crypto_openssl.c:10:30: fatal error: openssl/opensslv.h: No such file or directory
compilation terminated.
make: *** [../src/crypto/crypto_openssl.o] Error 1


Can anyone help me with that error I am running Ubuntu 13.04?


More From » wireless

 Answers
4

You need to build, or obtain, a different copy of hostapd. The one you have has been built with the option CONFIG_DRIVER_NL80211 set to N, rather than Y.



There are simple and detailed instructions how to rebuild it here → Hostapd building instruction. Rebuild it with the option enabled. You may have to google for hostapd.2.0.tar.gz, but do exactly as it mentioned in link.



As for the follow-up question/error try to install this library libssl-dev using this command:



sudo apt-get install libssl-dev

[#31478] Thursday, February 10, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
fenddy

Total Points: 361
Total Questions: 103
Total Answers: 113

Location: Turkmenistan
Member since Sun, Aug 2, 2020
4 Years ago
fenddy questions
Tue, Nov 22, 22, 10:11, 2 Years ago
Tue, Sep 27, 22, 09:16, 2 Years ago
Wed, Dec 28, 22, 13:09, 1 Year ago
Fri, Jun 18, 21, 14:04, 3 Years ago
;