Tuesday, October 3, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  23] [ 0]  / answers: 1 / hits: 109666  / 1 Year ago, sun, september 25, 2022, 7:50:25

After upgrading to 13.04 I am unable to start VMWorkstation. I get the following message:

Before you can run VMware, several modules must be compiled and loaded
into the running kernel.

Kernel Headers 3.8.0-19-generic

Kernel headers for version 3.8.0-19-generic were not found. If you
have installed them in a non-default path you can specify the path

Does anyone have any idea what to do next?

Ubuntu 13.04 64bit

If I direct the path to:


I get the following message:

C header files matching your running kernel were not found.



As suggested I run this in terminal:

cd /lib/modules/$(uname -r)/build/include/linux 

sudo ln -s ../generated/utsrelease.h

sudo ln -s ../generated/autoconf.h

sudo ln -s ../generated/uapi/linux/version.h

However, now I get the following:

Before you can run VMware, several modules must be compiled and loaded into the kernel

I INSTALL, the window closes and nothing happens.... Any ideas?


I installed this:

sudo apt-get install open-vm-tools open-vm-tools-dev open-vm-dkms open-vm-toolbox open-vm-tools-dev

And it all launched...

Many thanks for the suggestions and help... This is what I love about Ubuntu... it has a great helpful community... !

Note: Also found this which may help others too: HERE


Could not open /dev/vmmon: Is a directory.
Please make sure that the kernel module `vmmon' is loaded.

Failed to initialize monitor device.

Monitor settings all greyed out


Re-installation of Nvidia Drivers

More From » 13.04


Hit same problem here with Ubuntu 13.04 last month. At the time, upgrading to VMWare player 5.0.2 build-1031769 solved the problem. Fast forward a month, hit a new problem today after recent 13.04 updates, again VMWare would not start. Latest VM player version is still 5.0.2. Google lead me to this explanation:


Running the following vmware command with root privs solved the problem for me:

sudo vmware-modconfig --console --install-all


[#31568] Monday, September 26, 2022, 1 Year  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 352
Total Questions: 124
Total Answers: 95

Location: Grenada
Member since Tue, Oct 12, 2021
2 Years ago
ciousuntru questions