Wednesday, September 27, 2023
rated 0 times [  0] [ 0]  / answers: 1 / hits: 2146  / 2 Years ago, mon, june 7, 2021, 1:58:35

When I run aptitude install ia32-libs it gives me this output (on Pastebin due to length constraints of StackExchange).

The install fails, as it leaves ia32-libs in a Not Installed state. All other solutions that it suggests to me are pretty useless too.

I've tried purging every ppa and reverting to default repositories of Ubuntu, but it didn't help.

Could you help me?


this is the output of apt-get install ia32-libs-multiarch. as it seems, apt-get tries to be less "smart" compared to aptitude, and it prints a more comprehensive output.

i tried to manually install one of the packages that it recalls, gstreamer0.10-plugins-good:i386, but it lead to installing libpixman-1-0:i386, and as you can see there, it basically tries to remove everything that is installed on my machine!

what's going on?

More From » dependencies


lastly i found this solution, mainly by chance, since i don't know why this problem had occured in first place, and i don't know why this solution works. but it works.

for example i found that my system has difficulties installing libpixman-1-0 package. then this is what i must do:

1. open /var/lib/dpkg/status. this is a sensitive file, so consider taking a backup from it beforehand.

2. search for the line that is Package: libpixman-1-0. after this line, there should be a paragraph like this:

Package: libpixman-1-0
Status: install ok installed
Multi-Arch: same
Priority: optional
Section: libs
Installed-Size: 582
Maintainer: Ubuntu Developers <[email protected]>
Architecture: amd64
Source: pixman
Version: 0.24.4-1
Depends: libc6 (>= 2.14)
Pre-Depends: multiarch-support
Description: pixel-manipulation library for X and cairo
A library for manipulating pixel regions -- a set of Y-X banded
rectangles, image compositing using the Porter/Duff model
and implicit mask generation for geometric primitives including
trapezoids, triangles, and rectangles.
Original-Maintainer: Debian X Strike Force <[email protected]>

3. in my own case, there were multiple entries for this package, in fact two. find them all.

4. simply delete them!

5. now apt-get doesn't know anything about this package, and it assumes that it is not installed (though it is). so it thinks that any package that is dependent on libpixman-1-0 is now broken. you should run apt-get -f install. it simply tells apt-get to fix broken dependencies. in our case, it installs libpixman-1-0 properly.

6. now test again apt-get install ia32-libs-multiarch. if it doesn't install properly, find the other packages like libpixman-1-0 that are misbehaving. do these things for them too.

but how did i find that libpixman-1-0 is problematic? if you run apt-get install ia32-libs-multiarch it complains about some packages that are needed but can't be installed. try to install them by apt-get and it will tell you why they can't be installed. this way you can find the root of problem.

[#32951] Tuesday, June 8, 2021, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 437
Total Questions: 120
Total Answers: 107

Location: San Marino
Member since Fri, Jul 3, 2020
3 Years ago
afyess questions