Thursday, February 22, 2024
 Popular · Latest · Hot · Upcoming
rated 0 times [  4] [ 0]  / answers: 1 / hits: 4541  / 1 Year ago, mon, october 24, 2022, 9:44:31

I have a dual boot system of Ubuntu 12.10 and Windows 7. Stupidly, I set my default boot OS to Windows 7 using this method and set GRUB_TIMEOUT=0. Now when I boot, the Ubuntu red/purple screen flashes on and off and proceeds with booting Windows 7, effectively locking me out of Ubuntu.

Is there any way to:

  1. Change the "booter?" to Windows 7, which would not have the timeout.

  2. Hold down a key to over-ride the timeout? I've already tried shift without success.

  3. This link is exactly the problem I've been having, however I don't completely understand the part about booting from a live cd.

More From » boot


You can boot from an Ubuntu live CD. And then follow the instructions given in the link.

The idea behind using a live CD is to give you access to Linux partition via terminal. Earlier you changed the Grub configuration, You need to do it again. But you cannot (easily) do it from Windows.

So the easy way is to use Ubuntu Live and then when you boot in to it, use the terminal to edit the /etc/default/grub file.

Update the grub so that changes are taken into effect: update-grub

[#33403] Tuesday, October 25, 2022, 1 Year  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 9
Total Questions: 116
Total Answers: 119

Location: Grenada
Member since Sun, Dec 20, 2020
3 Years ago