Thursday, September 28, 2023
rated 0 times [  0] [ 0]  / answers: 1 / hits: 562  / 7 Months ago, thu, march 16, 2023, 10:22:46

I was trying to perform the the fix found at this link

It requires you to delete certain files from the /opt/google/earth/free folder and then add some new ones that you download. I deleted the files but the links to download the new ones were unusable. I was using gksudo nautilus so trash was disabled meaning I could not restore the files I had deleted. I the tried to go to the Google Earth website and reinstall it. I downloaded the .deb but when I tried to install it it gav me an error message saying "cannot install ia32-libs" I tried installing this via terminal and it gave me an error message saying

chad@chad-Lenovo-G570:~$ sudo apt-get install ia32-libs

[sudo] password for chad:

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:
ia32-libs : Depends: ia32-libs-multiarch
E: Unable to correct problems, you have held broken packages.

Now I am stuck without a functioning Google Earth. How can I fix this?

More From » package-management


Ok i finally figured it out. I ran the commands

sudo add-apt-repository ppa:gnome3-team/gnome3

sudo apt-get update

sudo apt-get install libcanberra-gtk-module

sudo apt-get install ia32-libs

[#33822] Friday, March 17, 2023, 7 Months  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 198
Total Questions: 108
Total Answers: 121

Location: Monaco
Member since Sun, Jan 16, 2022
2 Years ago