Thursday, September 21, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  13] [ 0]  / answers: 1 / hits: 17151  / 1 Year ago, thu, august 4, 2022, 8:42:17

I have an Upstart conf file in /etc/init which starts fine if i start it manually like this:

sudo initctl start myconf

If i run it without the sudo command i get the error name=(unset) error, which is due to user privileges, but that shouldn't be the problem when the job is initialised at system boot when Upstart kicks in right? (because thats all run by the root).

The content of the script is:

start on runlevel [2345]
stop on runlevel [^2345]

exec /spatial/

...where the runs a python script based server. When i check the status of the script right after i login to shell, it says stop/waiting. I also tried the conf file with "start on net-device-up" but nothing changes. Is there a way to see the Upstart system log or something similar that might help me debug the problem.


More From » upstart




You may want to consider converting it to a task while you debug it.

start on spatial-start


exec /spatial/

then from the console:

initctl emit spatial-start
initctl status spatial-start

[#34669] Saturday, August 6, 2022, 1 Year  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 403
Total Questions: 142
Total Answers: 112

Location: Iceland
Member since Sat, Sep 17, 2022
1 Year ago