Thursday, September 21, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  6] [ 0]  / answers: 1 / hits: 37140  / 2 Years ago, mon, october 11, 2021, 6:16:32

My 12.04 system hangs at "Checking battery state". At this stage, no commands work eg: Ctrl+Alt+f1, or Alt+f5.

I ran recovery mode, and ran the following commands:

sudo mount -o remount, rw /
sudo dpkg-reconfigure gdm

gdm was the only display manager installed, so I didn't get a GUI screen. I have an integrated graphics card "Intel Corporation Mobile 4 chipset Integrated Graphics Controller (rev 07)".

So I cannot install Nvidia drivers as everyone else suggests. I have gone through several similar questions but everyone suggests reconfiguring gdm or reinstalling graphic drivers.

I ran the following commands to get the latest x-swat drivers:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get upgrade

The system still hung at the same line.

The other option is to re-install Ubuntu, which is out of the question, since we have a very specific install for our project where the settings are very hard to duplicate.

Suggestions/Comments welcome.

More From » 12.04


Answer from the OP:

We installed lightdm and it showed similar behavior, i.e. it halted at a certain step.

However, then it was possible to press ctrlaltF1 and then login. The problem that there was the existence of /etc/init/lightdm.override. Inside the file was the word manual.

This was how it was present on install of lightdm, and then running 'sudo dpkg reconfigure lightdm'. Upon removing this file the system went to the login screen with no problems!

[#34743] Tuesday, October 12, 2021, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 112
Total Questions: 113
Total Answers: 113

Location: Guernsey
Member since Tue, Jul 6, 2021
2 Years ago