Monday, February 26, 2024
 Popular · Latest · Hot · Upcoming
2
rated 0 times [  2] [ 0]  / answers: 1 / hits: 16802  / 2 Years ago, wed, may 11, 2022, 2:14:33


I installed a couple of days ago Ubuntu 12.10 (64 bit).



I today tried ripping a CD in the MP3 format.



However, whenever I try to rip, it says it is missing an extra multimedia plugin "Gstreamer extra plug-ins (i386)".



I then try to install the :i386 version of the gstreamer-ugly plugins, but then I get the same problem but with the id3-demuxer (or something similar)



The Terminal output I get from both problems (but replace the "MPEG-1 Layer 3 (MP3) encoder" with the "ID3-demuxer" name) is:



james@clefairy:~$ rhythmbox

(rhythmbox:24122): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
Rhythmbox-Message: Missing plugin: gstreamer|0.10|rhythmbox|MPEG-1 Layer 3 (MP3) encoder|encoder-audio/mpeg, mpegversion=(int)1, layer=(int)3
/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed import gobject._gobject


It doesn't help that each time I have to install/remove the entire Gstreamer-ugly collection each time - I can't find that specific file.



The CD plays fine, it's the ripping plugin that doesn't seem to work.



I didn't have this problem previously on 12.04 (64 bit).


More From » rhythmbox

 Answers
7

Have a look at mc4man's post at http://ubuntuforums.org/showthread.php?t=2080739. Looks like we need to use a custom setting. Worked for me.


[#34787] Wednesday, May 11, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
atchcommo

Total Points: 114
Total Questions: 130
Total Answers: 101

Location: Cook Islands
Member since Sat, Oct 16, 2021
2 Years ago
;