Wednesday, September 27, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  1] [ 0]  / answers: 1 / hits: 2924  / 2 Years ago, thu, december 16, 2021, 6:11:51

The system specification

GRUB boot loader

OS: Windows 7 / Kubuntu 12.04 LTS

Keyboard: Roccat Isku

Motherboard: MSI Z77 MPower with the latest BIOS

SSD/HDD: Kingston HyperX 3K (AHCI in BIOS enabled), 2 other HDDs

I will provide more specific configuration if needed.

The problem

As stated in the topic I cannot navigate in the GRUB menu using mentioned keyboard (there is no problem when I use Logitech K360). I have tried both USB 2.0 and USB 3.0 ports.

I cannot enter BIOS menu as well, however if I enter it using other keyboard, Roccat seems to work and I can navigate in the BIOS menu without any issues.

Any ideas how can I fix that problem?

More From » grub2


Thanks for the answer, but I have already solved the problem (after contacting ROCCAT and MSI): it was a Z77 chipset problem.

Some manufacturers already solved the problem - f.x. ASRock.

MSI has developed a beta BIOS release.

BIOS beta, flashing instructions and whole discussion is available here:

Works perfect allowing you to enter the BIOS, navigate in the BIOS and navigate in the GRUB.

[#35035] Saturday, December 18, 2021, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 78
Total Questions: 130
Total Answers: 98

Location: Peru
Member since Fri, Oct 14, 2022
1 Year ago