Sunday, September 24, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  1] [ 0]  / answers: 1 / hits: 5858  / 5 Months ago, sat, april 29, 2023, 5:37:29

I have installed the server image of 20.04 LTS (Focal Fossa).

My 64-bit database product from IBM requires a 32-bit library for compatibility reasons , but this 32-bit library is not found when I apt-get install libpam0g:i386.

(This 32-bit compatibility library was available on 18.04 LTS and 16.04 LTS).

The package name is 'libpam0g:i386'.
This is what I see:

# apt-get update
Hit:1 focal InRelease
Get:2 focal-updates InRelease [89.1 kB]
Hit:3 focal-backports InRelease
Get:4 focal-security InRelease [97.9 kB]
Get:5 focal-updates/main amd64 c-n-f Metadata [368 B]
Get:6 focal-security/main amd64 c-n-f Metadata [344 B]
Fetched 188 kB in 1s (248 kB/s)
Reading package lists... Done

# apt-get install libpam0g:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libpam0g:i386

Any suggestions?


grep -r ^deb /etc/apt/ --include="*.list" 
/etc/apt/sources.list:deb focal main restricted
/etc/apt/sources.list:deb focal-updates main restricted
/etc/apt/sources.list:deb focal universe
/etc/apt/sources.list:deb focal-updates universe
/etc/apt/sources.list:deb focal multiverse
/etc/apt/sources.list:deb focal-updates multiverse
/etc/apt/sources.list:deb focal-backports main restricted universe multiverse
/etc/apt/sources.list:deb focal-security main restricted
/etc/apt/sources.list:deb focal-security universe
/etc/apt/sources.list:deb focal-security multiverse

More From » 20.04


It seems that for ubuntu 20.04 the libpam0g:i386 is renamed to libpam_systemd:i386

The following command worked for me, and delivered the 32-bit library that I needed:

dpkg --add-architecture i386

sudo apt install libpam-systemd:i386


At first I tried manual installation of libpam0g:i386 , and it also worked but with more steps for manual dependency handling. Not recommended.

copy libpam0g_1.3.1-5ubuntu4_i386.deb
to the target server.

The target server has no X server (is headless), so in an ssh session:

apt update

dpkg --add-architecture i386

apt install libaudit1:i386

apt install libc6:i386

dpkg --install libpam0g_1.3.1-5ubuntu4_i386.deb

This installed the dependencies first, then the required libpam0g:i386, and the IBM software accepted this. Much easier to use apt install libpam-systemd:i386 because that delivered the dependencies automatically.

[#3698] Saturday, April 29, 2023, 5 Months  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 314
Total Questions: 124
Total Answers: 97

Location: Dominican Republic
Member since Wed, Mar 17, 2021
3 Years ago
brasiplacar questions
Sat, Sep 4, 21, 13:11, 2 Years ago
Tue, Jan 10, 23, 06:22, 9 Months ago
Wed, Oct 13, 21, 15:19, 2 Years ago
Wed, May 4, 22, 00:06, 1 Year ago
Thu, Jan 5, 23, 15:40, 9 Months ago