Monday, February 26, 2024
 Popular · Latest · Hot · Upcoming
2
rated 0 times [  2] [ 0]  / answers: 1 / hits: 1926  / 2 Years ago, fri, july 15, 2022, 5:36:40

I've changed my build/compile commands on geany to use Intel's Fortran:



    ifort -c "%f"
ifort "%f" -o "%e"


When I try compiling, I get the following error:



ifort "file.f90" -o "file" (in directory: ...)
Compilation failed.
/bin/sh: 1: ifort: not found


However, I can type



    ifort -o file file.f90


in terminal and it will compile with no problem. I can open geany from terminal with the command "LANG=C geany --verbose" which fixes geany's inability to find ifort, but have not found a way to get the unity launcher to use that.



So: does anyone know how to get unity launcher to use the command or fix geany to accept ifort without above command?


More From » intel

 Answers
0

Add ifort as a symbolic link in the /usr/bin folder. That solves the whole problem.



sudo ln -s /opt/intel/composer_xe_2013.1.117/bin/intel64/ifort /usr/bin/ifort


Replace the path with whatever version of Intel Composer you are using.


[#38545] Friday, July 15, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
utschang

Total Points: 357
Total Questions: 120
Total Answers: 119

Location: Croatia
Member since Sat, May 2, 2020
4 Years ago
;