Tuesday, October 3, 2023
rated 0 times [  14] [ 0]  / answers: 1 / hits: 21541  / 2 Years ago, thu, december 9, 2021, 10:18:23

I am running Ubuntu 12.04 LTS. I wanted to install Java and so I downloaded the 32-bit self extracting .bin file from http://www.java.com and tried to install it according to their instruction.

First I made the file an executable one. Then created /usr/java/. After that I have to run this command: ./jre-7u<version>-linux-i586.bin.

But I'm stuck here. My Java version is Java 6 u32. When I enter the command it says "no such file or directory". What to do? Please help. Also I'm trying to install 32-bit Java on my 64-bit Precise. Could that possibly be the problem?

I tried to follow second answer by Jonas Christensen. I tried to open it, it says file is an unknown type. I tried the terminal command: ./jre-6u31-linux-i586.bin. But it gave this:

./jre-6u32-linux-i586.bin: 86: ./jre-6u32-linux-i586.bin: ./install.sfx.5736: not found
Failed to extract the files. Please refer to the Troubleshooting section of the Installation Instructions on the download page for more information.

More From » installation


Please see the "bug" described at: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6500693

Resolve by installing 32 bit libs:

sudo apt-get install ia32-libs

[#38659] Friday, December 10, 2021, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 123
Total Questions: 109
Total Answers: 113

Location: South Korea
Member since Fri, Sep 11, 2020
3 Years ago