Tuesday, September 26, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  0] [ 0]  / answers: 1 / hits: 4059  / 1 Year ago, thu, august 4, 2022, 2:28:10

I'm having problems on updating Ubuntu 11.10 to 12.04, I've tried to update all possible ways.

I'v downloaded Ubuntu 12.04 from cd...but when booting the upgrade option wont appear...just: Install alongside-Erase disk and Install-Other.

So after waiting 5 days I thought that be enough to update the mirror for my contry, Spain.
Even though is not showing any upgrade to 12.04 just normal updates...I've tried changing the mirrors and changed to main server and luck either...after googling a bit..I've found this mirror which does host an upgrade to 12.04 and switched to that mirror with no luck on upgrade either. ftp.halifax.rwth-aachen.de

Read here and there and tried Sudo apt-get update Sudo apt-get dist-upgrade and do-release-upgrade

No luck with all of them....in doing do release upgrade I get:

Checking for a new ubuntu release
Unhandled exception in thread started by <bound method MetaReleaseCore.download of <UpdateManager.Core.MetaRelease.MetaReleaseCore object at 0x7f03a9f09fd0>>
Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/UpdateManager/Core/MetaRelease.py", line 261, in download
uri=urllib2.urlopen(req, timeout=20)
File "/usr/lib/python2.7/urllib2.py", line 126, in urlopen
return _opener.open(url, data, timeout)
File "/usr/lib/python2.7/urllib2.py", line 394, in open
response = self._open(req, data)
File "/usr/lib/python2.7/urllib2.py", line 412, in _open
'_open', req)
File "/usr/lib/python2.7/urllib2.py", line 372, in _call_chain
result = func(*args)
File "/usr/lib/python2.7/urllib2.py", line 1201, in http_open
return self.do_open(httplib.HTTPConnection, req)
File "/usr/lib/python2.7/urllib2.py", line 1174, in do_open
r = h.getresponse(buffering=True)
File "/usr/lib/python2.7/httplib.py", line 1027, in getresponse
File "/usr/lib/python2.7/httplib.py", line 407, in begin
version, status, reason = self._read_status()
File "/usr/lib/python2.7/httplib.py", line 365, in _read_status
line = self.fp.readline()
File "/usr/lib/python2.7/socket.py", line 447, in readline
data = self._sock.recv(self._rbufsize)
socket.timeout: timed out
^CTraceback (most recent call last):
File "/usr/bin/do-release-upgrade", line 83, in <module>

After doing what jhon suggested I got no network working with ethernet or wireless either.

Any ideas??I think netroot is what crashed the networking..?

More From » 11.10


Have you tried booting with RecoveryMode and then attempting to repair you packages? Here's what I think I would do.

  1. Boot to your GRUB boot menu.

    Note: If the GRUB menu does not appear when you boot, hold down the Shift key immediately after the BIOS finishes loading and booting begins. The GRUB menu should appear. If instead you see the Ubuntu logo, then you've gone too far. Try again.

  2. The Grub menu should look something like this:

    Ubuntu, with Linux 3.2.0-23-generic
    Ubuntu, with Linux 3.2.0-23-generic (recovery mode)
    Memory test (memtest86+)
    Memory test (memtest86+, serial console 115200)

    Select the (recovery mode) GRUB menu item and press enter.

  3. You should eventually see the RecoveryMode menu (image below).

    Ubuntu RecoveryMode menu

Now perform the following steps ...

  1. Select & run the fsck entry in the Recovery Menu.

    When you boot into RecoveryMode the filesystem in your root (/) partition is mounted as read-only as a safety measure. If fsck completes successfully, your install partition will be remounted as read/write allowing you to make changes.

  2. Select & run the network menu entry.

    This should enable you to access the Internet and download updates during the next step.

  3. Select & run the dpkg menu entry.

    This will examine the software packages on your system. If a problem is found, it will attempt to repair them if it can.

  4. When the processing for dpkg has completed you can resume booting. However, you may need to reboot for your graphics drivers to be properly initialized.

[#38825] Thursday, August 4, 2022, 1 Year  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 195
Total Questions: 122
Total Answers: 104

Location: Oman
Member since Tue, Feb 7, 2023
8 Months ago