Tuesday, October 3, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  15] [ 0]  / answers: 1 / hits: 35601  / 1 Year ago, wed, august 3, 2022, 5:43:44

When I try to start XAMPP with sudo /opt/lampp/lampp start command it gives me a message like this.

Starting XAMPP for Linux 1.7.7...
XAMPP: Another web server daemon with SSL is already running.
XAMPP: Starting MySQL...
XAMPP: Couldn't start MySQL!
XAMPP: XAMPP-ProFTPD is already running.
XAMPP for Linux started.

What is this and how can I find what was this another web server daemon with SSL.
How to stop this server ?

More From » apache2


This is a peculiar error you will get if you run XAMPP in LINUX.

Assumption: XAMPP is unzipped @ /opt/ folder.

If you get the error "XAMPP: Another web server daemon with SSL is already running" when you run ./lampp start. Simply follow the steps below to get rid of this error:

  1. Open the file /opt/lampp/etc/httpd.conf.

  2. Search the Listen 80 and change it to some other port (e.g. Listen 2145) (Line No. 40).

  3. Open the file /opt/lampp/etc/extra/httpd-ssl.conf.

  4. Search the Listen 443 and change it to some other port (e.g. Listen 16443) (Line No. 39).

  5. Open the file /opt/lampp/lampp

  6. Search for the port testport 80 and replace it to testport 2145. Also change the testport 443 to testport 16443. (Happens to be the Line No. 197, 214)

  7. Now go and run /opt/lampp/lampp start. It should work now.

Note: Line numbers may be different.

[#41368] Friday, August 5, 2022, 1 Year  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 336
Total Questions: 105
Total Answers: 113

Location: Vietnam
Member since Sun, Oct 18, 2020
3 Years ago