Thursday, February 22, 2024
 Popular · Latest · Hot · Upcoming
2
rated 0 times [  2] [ 0]  / answers: 1 / hits: 21585  / 1 Year ago, tue, february 14, 2023, 4:30:48

I am trying to use synergy and when I run synergyc or synergys it shows the error:




synergys: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found
(required by synergys)




I don't have that version as shown by this command:



strings /usr/lib/libstdc++.so.6 | grep GLIBC
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBC_2.0
GLIBC_2.3
GLIBC_2.4
GLIBC_2.1
GLIBC_2.3.4
GLIBC_2.1.3
GLIBC_2.3.2
GLIBC_2.2
GLIBCXX_FORCE_NEW
GLIBCXX_DEBUG_MESSAGE_LENGTH


How can I get GLIBCXX3.4.14? I tried apt-get install libstdc++6-4.4-dbg libstdc++6-4.4-dev, but that wont install that version.


More From » 10.04

 Answers
2

I uninstalled synergy and reinstalled it using Synaptic (Ubuntu Software Center), this time it worked.



sudo apt-get remove synergy
sudo apt-get install synergy

[#41397] Wednesday, February 15, 2023, 1 Year  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
pheter

Total Points: 223
Total Questions: 111
Total Answers: 119

Location: Guadeloupe
Member since Sat, Aug 22, 2020
4 Years ago
;