Thursday, February 22, 2024
 Popular · Latest · Hot · Upcoming
20
rated 0 times [  20] [ 0]  / answers: 1 / hits: 10710  / 1 Year ago, tue, march 7, 2023, 1:30:32

I want to swap Capslock with Backspace and came only so far as to mix them both together. By that I mean: hitting Capslock does work like the Backspace key, but also activates Caps (including the LED).



When I was using Gnome, the Keyboard Settings would let me easily do the switch. In XFCE these options are missing, so I tried via .Xmodmap and xkeycaps. Xkeycaps even lets me export the stuff to .Xmodmap, but somehow it does not work. I'm missing something here!



Current .Xmodmap (commented out because it gives errors "bad keysym in remove modifier list 'Caps_Lock', no corresponding keycodes", this was mostly described in forums)



keycode  66 = BackSpace
! remove Lock = Caps_Lock
remove Mod5 = Mode_switch Mode_switch


Referencing xmodmap to load in .profile etc did not work either.
I could live with installing the Gnome-Keyboard Settings tool on my xfce system, if nothing else helps - which package is it?



EDIT:
setxkbmap -option caps:backspace works, BUT: key does not repeat on holding down UNLESS i use xmodmap -e "clear Lock" as well. Not quite elegant, but apparently working.


More From » xfce

 Answers
6

To close this one, I'll add my current fix. Maybe someone can use it too. Put this in a script, autostart it with DE:



setxkbmap -option caps:backspace
setxkbmap -option shift:both_capslock
xmodmap -e "clear Lock"

[#42348] Tuesday, March 7, 2023, 1 Year  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
rtbrbab

Total Points: 461
Total Questions: 126
Total Answers: 117

Location: Saudi Arabia
Member since Fri, Jul 1, 2022
2 Years ago
rtbrbab questions
Fri, May 5, 23, 14:22, 10 Months ago
Tue, Nov 16, 21, 14:41, 2 Years ago
Thu, Mar 23, 23, 20:47, 12 Months ago
Sat, Jun 18, 22, 21:36, 2 Years ago
;