Saturday, September 23, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  2] [ 0]  / answers: 1 / hits: 3928  / 8 Months ago, fri, february 3, 2023, 12:22:43

I've recently upgraded to Ubuntu 11.10 and since then, I haven't been able to checkout code from Google Code. I can't get it with either svn or git, but they were both working before the upgrade (so I'm assuming it's a problem with 11.10).


$ svn checkout project --username [email protected]
svn: OPTIONS of '': SSL handshake failed: Secure connection truncated (


$ git clone https://[email protected]/p/project/ 
Cloning into project...
error: gnutls_handshake() failed: A TLS packet with unexpected length was received. while accessing https://[email protected]/p/project/info/refs

fatal: HTTP request failed

Any ideas?

git version
svn, version 1.6.12 (r955767)
openssl 1.0.0e-2ubuntu4
libneon27-gnutls 0.29.6-1


Just confirmed with my 11.04 netbook that I can checkout Google Code via https with subversion.

I compiled subversion-1.7.0 from source using the neon 0.29.6 and openssl with no luck. It now gives svn: E175002.

Edit 2:

Just to be clear, I only seem to have this problem with Google Code. I can check out code from all of the other repositories that I've tried.

More From » 11.10


I also had this problem when moving to 11.10 (although with an Assembla SVN repo, not Google code). This solution from Jan Kester's blog worked for me:

sudo apt-get install libneon27
cd /usr/lib/
sudo rm
sudo ln -s /usr/lib/

Hope this helps.

[#42892] Friday, February 3, 2023, 8 Months  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 223
Total Questions: 116
Total Answers: 124

Location: Slovenia
Member since Wed, Apr 6, 2022
1 Year ago