Wednesday, September 27, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  3] [ 0]  / answers: 1 / hits: 6069  / 10 Months ago, fri, december 23, 2022, 6:21:32

I have Ubuntu 11.04 (Natty Narwhal) and the sound indicator in the panel sometimes breaks down. I assume it is probably because the sound system crashes or something.

When this happens, The sound indicator shows just three dashes instead of the current volume, I can't change the volume using the Volume Up/Volume Down keys on my keyboard, not can I change it using the slider that shows when I click on the sound indicator.

When I click on the sound indicator and then click on the "Sound preferences" in the popup menu, a message box appears, saying something like "Waiting for sound system to respond". I found that this is due to crashed pulseaudio (whatever that is) and I should type pulseaudio --start to start it again. After I do that, I can open the sound preferences and adjust the volume from there, but I still can't change the volume using the multimedia keys on my keyboard, nor using the volume slider in the sound indicator.

So my questions:

  1. Is there a way to stop pulseaudio from crashing (assuming this is the cause for the indicator to break down)?

  2. If not, is there at least a way to restore the volume indicator after the pulseaudio system has been restarted, so the volume keyboard shortcuts and the slider work (maybe a way to restart the indicator itself)?

More From » 11.04


PulseAudio is an audio system that, among other things, enables multiple applications to use the audio interface at the same time. It can also be used for things like sharing audio over the network. So, PulseAudio is a good thing.

  1. If PulseAudio keeps crashing, then something is wrong. The best way for you to prevent that from happening, is to file a bug on and get the developers attention. We don't exactly have a configuration option to enable or disable application crashes. :)

  2. Yes, restarting the indicators might be a successful workaround. In order to do that, you'll press AltF2 and type killall unity-panel-service

If restarting PulseAudio and then restarting the panel service works, then you might want to combine them in a script so you can do both things at once. You can then create a new text file in Gedit, paste the following and make the file executable. You do that by right clicking on the file, selecting properties > permissions > Allow execution of file. Afterwards, you can run that script as a normal program.

This is the script itself:

pulseaudio --start
killall unity-panel-service

So, if you call the file and place it in your home directory, you'll be able to run it by pressing alt+f2 and typing ~/

However, even if this workaround works, you should still file a bug on Launchpad so that the problem itself gets fixed for you and everyone else.

[#43332] Saturday, December 24, 2022, 10 Months  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 291
Total Questions: 123
Total Answers: 104

Location: Tuvalu
Member since Wed, Mar 29, 2023
7 Months ago