Saturday, September 23, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  3] [ 0]  / answers: 1 / hits: 2237  / 1 Year ago, wed, september 28, 2022, 1:07:25

My laptop was working perfectly, but suddenly today I turned it on and after GRUB, the Plymouth splash flashed and then the screen went black with a blinking cursor. After blinking like 6 times, the cursor disappears and the screen stays completely black. Ubuntu won't boot after that and the computer is non-responsive to Ctrl+Alt+Del, so I have to reboot by holding the power button and then turning it back on.

I tried using the Recovery Mode to see if it was a problem with X or whatever... But it always seemed to crash when it was going to ask me to login. I did some research on the Internet and then tried holding Shift while booting up and then pressing 'e' when GRUB showed up. I then removed "quiet splash" and tried with "text" there. Computer booted up and I didn't get any errors. Logged in with my user and password, and then did a manual startx. After that the laptop starts and runs perfectly, as I'm using it right now to write this message.

I think the problem is something in gdm, but I don't know what. I thought maybe it was a problem with Plymouth, but I imagine failsafex from Recovery Mode would skip Plymouth and just send you to log in.

Does anybody have any idea how to get gdm to work again? Or any idea what could be wrong with it?

More From » 10.04


If plymouth displays but gdm fails to start up at boot, the system may have left you on a blank VT (virtual terminal) and the end of the boot sequence. You can try pressing Alt+F1 (or Alt+F2) to switch terminals and get to a text login. (plymouth in Ubuntu boots on VT7, the same VT used for the X display; VTs 1-6 are reserved for text console logins.)

You can also try booting without any of the 'quiet', 'splash', or 'text' options. If this allows gdm to start, then there is a bug in the interactions between plymouth and gdm affecting your system. In that case, you should file a bug report against Ubuntu in launchpad:

[#43444] Thursday, September 29, 2022, 1 Year  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 335
Total Questions: 111
Total Answers: 119

Location: Belize
Member since Mon, Jun 20, 2022
1 Year ago