Friday, September 29, 2023
rated 0 times [  2] [ 0]  / answers: 1 / hits: 11741  / 11 Months ago, sat, november 19, 2022, 10:41:31

I have tried several times to install Natty on its own partition on my laptop (WinXP, Intel x86) using UNetBootin, but it always fail.

There is a dialog box:

Failed to unmount partitions

The installer needs to commit changes to partition tables,
but cannot do so because partitions on the following could
not be unmounted.


Please close any applications using these mount points.

Would you like the installer to try to unmount these partitions again?

If I click on "continue" Ubiquity will hang up, that is, the slideshow will play forever. I do not have a built-in optical drive and I'm not currently using any peripheral.

I have tried sudo umount /cdrom it says that cdrom is busy. Then the command fuser /cdrom returns "Stale NFS file handle".

How can I work around this to install Ubuntu?

More From » system-installation


It is a bug in Ubiquity:

I eventually found those threads after a long, really non-trivial search... Interesting workarounds are listed there. However I won't vouch for them (see comment). Be careful if you need install Ubuntu from an ISO image directly from your disk!

[#43624] Sunday, November 20, 2022, 11 Months  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 194
Total Questions: 129
Total Answers: 110

Location: North Korea
Member since Tue, Jun 16, 2020
3 Years ago
atelti questions
Fri, Aug 26, 22, 02:44, 1 Year ago
Sat, Dec 10, 22, 21:37, 10 Months ago
Sun, Apr 16, 23, 03:34, 6 Months ago
Sat, Apr 9, 22, 13:57, 2 Years ago