Tuesday, October 3, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  99] [ 0]  / answers: 1 / hits: 316559  / 2 Years ago, wed, march 16, 2022, 10:34:12

I'm using the Arduino IDE in Ubuntu, and am having issues with the serial port. It has worked in the past, but for reasons that may be unnecesary, I felt the need to change the ownership of some of the files from root ownership to my users ownership.

This made the IDE work correctly, but I lost the ability to use the correct serial port. In the dev folder, the port I need is listed as permission 166. Someone (who is no longer in the area to help me) swapped the permissions to 666, which made it all work gloriously.

However, it reverted back as soon as I restarted my computer, and if I now try to use the command:

sudo chmod 666 ttyACM0

nothing happens. No error messages, but no permission change either.

How can I change it, and how can I get it to change permanently.

I apologize if this question is overly simplistic or unclear, I'm an ubuntu noob, and I wouldn't begrudge feedback!

More From » permissions


The issue with the permissions for /dev/ttyACM0 can be permanantly solved by adding yourself to the dialout group.

You can do this with:

  1. sudo usermod -a -G dialout $USER

  2. Logout and then log back in for the group changes to take effect.

[#43772] Thursday, March 17, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 92
Total Questions: 111
Total Answers: 120

Location: Jordan
Member since Wed, Jun 17, 2020
3 Years ago
antorchestr questions