Wednesday, September 27, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  1] [ 0]  / answers: 1 / hits: 1300  / 2 Years ago, wed, april 6, 2022, 11:43:58

I have a Creative Zen MX MP3 Player, and whenever I rip a CD in Banshee media player and then transfer the files over to my player, the metadata seems to not be there, or not displaying (E.G. No album art, no artist, no track title; just displays filename.) I have "Write metadata to files" ticked in the preferences but it still doesn't show up. Does anybody know of a CD Ripper compatible with it? I will probably end up buying an Android phone and listen to my music on that, but I'd like to try and find a solution for my player at the moment.

Also, I'm a bit of a Linux noob, so whilst I can enter commands into the terminal, find lines in files to edit, etc. I might need a bit of help :)

Edit: ADDITIONAL INFORMATION; Files downloaded from Amazon MP3 work out of the box, I download them directly through the official client or webiste.


Tried using Asunder ripper to rip CDs, it adds details to tracks successfully, but there's no track numbers, so my Zen MX just sorts the tracks alphabetically by default. Also, on a track with an é in it appears as mojibake, even though I'm pretty sure my Zen can display "é" as it displays track names that have ü and ß in them. Could this be to do with them being ripped under Linux and not Windows?

Ok, so here's the images; I ripped Now 74 as I hadn't ripped it on Linux yet, and I re-ripped it on Windows, just to make sure.

When ripped by Banshee:

enter image description here

When ripped by Asunder:


When ripped by Creative Centrale, the official (albeit, Windows only) client for my MP3 player:


More From » banshee


I think the issue could be the tags that CD Rippers use - they usually create ID3v2.4 tags which some Zens can't handle.

Possible Solution 1

Asunder CD ripper will rip to either ID3v1 or ID3v2.x tag format depending upon the information on the CD.

Install asunder and lame from the software center.

Run asunder - and select the preferences button followed by the Encode tab.

Tick the MP3 checkbox and uncheck the ogg checkbox.

Then rip your CD.

Possible Solution 2

Use Banshee or another tool to import your CD. Banshee will tag your mp3 in ID3v2.4 format

Correcting ID3 Tag information

Since Asunder will sometimes not write ID3v2.3 tags and Banshee will write to a tag format that your Zen will not understand, you will need to use another application to correct the tag format.

EasyTag is such a program - just to confuse everyone, there are two versions in the Software Center. Check EasyTag - Help - About - Extensions. If it says v2.3 support is disabled, then install the other "easytag" in the software center - on natty this is version 2.1.6.

Ensure EasyTag Settings - Preferences look like this:
enter image description here

  1. highlight the file or files and add some text to the comment field. N.B. you can use the usual shift - click method to highlight multiple files.
    enter image description here

  2. click the save button - a prompt should display indicating that it would like to write the changed tag information back to the file. Click Yes

Transfer to your Zen and confirm that the tag information is displayed correctly.

[#43864] Wednesday, April 6, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 279
Total Questions: 106
Total Answers: 96

Location: Fiji
Member since Wed, Mar 29, 2023
7 Months ago
uxuriousrnal questions
Wed, Mar 9, 22, 09:04, 2 Years ago
Mon, Jul 18, 22, 01:48, 1 Year ago
Wed, Apr 13, 22, 01:15, 1 Year ago
Thu, Aug 26, 21, 22:01, 2 Years ago