Thursday, February 22, 2024
 Popular · Latest · Hot · Upcoming
rated 0 times [  3] [ 0]  / answers: 1 / hits: 9449  / 1 Year ago, wed, february 22, 2023, 5:25:39

I've got a fairly fresh install (a month old) of Kubuntu without much modification done to it and I'm having massive issues connecting to any wireless network. The computer can see the networks available and on trying to connect to my home network it will get to Setting Network Address before waiting for a while and then cutting the connection.

Sometimes the connection works, most of the time it doesn't. I've got this script which sometimes helps, but sometimes doesn't:

sudo ifconfig wlan0 down
sudo dhclient -r wlan0
sudo ifconfig wlan0 up
sudo dhclient wlan0

I don't really know too much about how to troubleshoot this issue (I'm a bit of a *ubuntu noob) - can anyone help?

here's my wifi card info :

   description: Wireless interface
product: Centrino Advanced-N 6205
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan0
version: 34
serial: a0:88:b4:58:d1:c4
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlagn driverversion=2.6.38-10-generic firmware= build 35905 ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
resources: irq:48 memory:f2500000-f2501fff

More From » wireless


It's probably not related to network manager but wireless drivers:

Solution is in the last post in the link, although it's not easy.

Just to avoid link rot: solution is to install from source compat-wireless using laptop's wifi firmware.

[#43959] Thursday, February 23, 2023, 1 Year  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 390
Total Questions: 123
Total Answers: 110

Location: Puerto Rico
Member since Sat, Mar 13, 2021
3 Years ago
riffnkful questions
Thu, Nov 17, 22, 04:24, 1 Year ago
Mon, Nov 28, 22, 01:40, 1 Year ago
Mon, Jul 11, 22, 13:24, 2 Years ago
Sun, Feb 5, 23, 05:06, 1 Year ago