Tuesday, October 3, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  18] [ 0]  / answers: 1 / hits: 3861  / 2 Years ago, fri, february 25, 2022, 10:23:49

I normally download all .deb packages and just copy the packages from /var/cache/apt/archives directory to the rest of the computers, saving me to have to download all the updates and programs again. But since Ubuntu 11.04, the directory keeps deleting the oldest file or some kind of delete method that literally resets the amount of packages there. So then I need to download them again on the rest of the PCs. The files stay there for a couple of days, but then "magically" it's not there anymore after some days.

So what do I need to do to tell Ubuntu NOT to eliminate any files from /var/cache/apt/archives, not even the previous versions of the same package? I do not want it to delete anything from there.

Just to add, I install packages using aptitude or synaptic.

More From » 11.10


Take a look at /etc/apt/apt.conf.d/20archive.

In there there are a few lines used by the daily apt cron job:

APT::Archives::MaxAge "30";
APT::Archives::MinAge "2";
APT::Archives::MaxSize "500";

Those are the defaults. You should get what you want by setting all three to 0.

You can look at the headers of /etc/cron.daily/apt for more information.

[#44357] Saturday, February 26, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 391
Total Questions: 103
Total Answers: 104

Location: South Sudan
Member since Thu, Feb 4, 2021
3 Years ago
ranquctive questions