Thursday, February 22, 2024
 Popular · Latest · Hot · Upcoming
4
rated 0 times [  4] [ 0]  / answers: 1 / hits: 3203  / 1 Year ago, wed, november 2, 2022, 3:44:24

On Ubuntu 10.04 I recently installed Python 2.7.1 (ActivePython from ActiveState). I use meld to diff code and had no issues with Python 2.6.5, but after moving to 2.7.1 I get the following error when I execute meld:




Meld requires pygtk 2.8.0 or higher




Looking in Synaptic Package Manager, I have python-gtk2 installed which I believe maps to pygtk, but since meld cannot find it, does that mean it is installed for 2.6.5?



If I run the following:




pip install pygtk




I get:




ImportError: No module named dsextras




dsextras seems to be part of PyGObject but if I try to do:




pip install pygobject




I get an error that indicates that this type of installation is only supported on Windows:




Not supported, ok [y/N]? Error:
distutils build only supported on
windows




What's the recommended way of migrating to a newer Python version? Is it possible to import the packages from 2.6.5 into 2.7.1 or do I risk running into compatibility issues?


More From » 10.04

 Answers
2

This is a better way of installing Python 2.7 into Ubuntu 10.04. What's the best way to get Python 2.5 and 2.7


[#44744] Thursday, November 3, 2022, 1 Year  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
assionortly

Total Points: 423
Total Questions: 121
Total Answers: 115

Location: Chad
Member since Wed, Sep 30, 2020
3 Years ago
;