Friday, September 29, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  6] [ 0]  / answers: 1 / hits: 4150  / 12 Months ago, thu, november 10, 2022, 5:25:51

I have a problem running Vim. I am editing files with recognisable file extensions - .xml, .php - however the text is black. This would not be a problem except I run terminal windows with a black background.

I can get to see my files by setting the terminal session to have a white background, but I would like a fix rather than a workaround.

I have renamed/moved the .vim and .viminfo files in my home directory but that has not magically restored my vim settings (that were fine yesterday morning).

Any ideas?

More From » vim


Try informing vim that your terminal has a black background with :set bg=dark. If your text is still black, try setting an environment variable that says your terminal is capable of color before you start vim by running export TERM=xterm-color.

[#44855] Thursday, November 10, 2022, 12 Months  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 113
Total Questions: 102
Total Answers: 114

Location: Northern Mariana Islands
Member since Fri, Jan 15, 2021
3 Years ago