Sunday, September 24, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  0] [ 0]  / answers: 1 / hits: 4120  / 8 Months ago, thu, february 16, 2023, 9:29:47

I'm in the process of rebuilding my IBF (invisible bridging firewall) as Ubuntu 10.04.2 LTS. In the past I have dealt with ipv6 by way of disabling it entirely. This time around I want to leave it enabled and filter it with ip6tables, etc.

All my config seems fine, except I cannot seem to discover a working method for getting the 'fe80' addresses off of my bridge-interface-cards. It might be understandable for br0 to get such an address, but under no circumstances would I want anything speaking on any layer higher than '2' directly to eth0 or eth1.

Things I have tried thus far include:

1) Specifying 'inet6 manual' entries in 'interfaces'

2) Specifying 'inet6 static' and 'address ::'

3) sysctl.conf '0' for various inet6 settings found via Google

4) 'post-up echo 0 >' as above

Nothing seems to work. If I run a 'ip -6 addr del' command, I can get it to go away, but that (as you likely know) doesn't last and it doesn't survive a reboot.

What I want is the equivalent to ipv4's '' addressing - a non-functional, yet not unconfigured address.


More From » ipv6


I'm not sure what you are setting in sysctl.conf, but the settings in it should automatically be applied when you restart. You should be able to apply them right away with something like sudo sysctl -p
If you are having trouble with it not applying, you may need to specify the interface like this:
net.ipv6.conf.eth0.<something> = 0 instead of net.ipv6.conf.all.<something> = 0.

From what I understand, if you have IPv6 on you will have a link local address (but I could be wrong).

[#44951] Saturday, February 18, 2023, 8 Months  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 226
Total Questions: 116
Total Answers: 136

Location: Guernsey
Member since Sun, Jan 10, 2021
3 Years ago